Archived

This topic is now archived and is closed to further replies.

  • 0

Facebook All-in-One Getting 404 on Pagelines Page options

Question

Posted · Report post

Since I added Facebook AIO, I'm getting a 404 whenever I click Pagelines>>>Page Options. I have saved my permalinks and contacted my host provider about mod-security. They say their mod_security is a top-down feature on their entire server and can't change it.

 

URL http://suburbanmillennial.com/

 

Any ideas?

Share this post


Link to post
Share on other sites

9 answers to this question

Posted · Report post

Yes mod_security IS server wide, it is an apache module they have installed.

 

You can however add per folder directives either with htaccess ( if they have it enabled ) or via the vhost settings in httpd.conf.

 

Being a web host they should already know this.

Share this post


Link to post
Share on other sites

Posted · Report post

How many other sections do you have active?

 

Usually the page options 404 is because PHP added a limit to the amount of options allowed in a post object, the default is 1000.

 

This can be adjusted via .htaccess/php.ini depending on your host.

 

If it WAS mod_sec then your host would be able to tell us the error by looking at their audit log. Which is why i dont think it is that because either there was nothing in the logs, or they dont know where to look ;)

Share this post


Link to post
Share on other sites

Posted · Report post

I only have 3 active sections. Branding, Simplicitate menu and secondary nav which I'm not even using.

 

How do I adjust htaccess/php.ini ? or rather - What line do I adjust and what value?

Share this post


Link to post
Share on other sites

Posted · Report post

Ist you need to get your host to look at the PHP logs and find out from the logs what is causing the error. 

Share this post


Link to post
Share on other sites

Posted · Report post

Please let us know if you still need assistance, otherwise I will close this topic in 7 days. Thanks!

 

@MrFent I'd recommend asking Simon about that in developer chat. :)

Share this post


Link to post
Share on other sites

Posted · Report post

Ok - I just caused the error. My host provider gave me this:

[Fri May 17 09:17:18 2013] [error] [client 67.86.220.183] ModSecurity: Output filter: Failed to read bucket (rc 70007): The timeout specified has expired [hostname "suburbanmillennial.com"] [uri "/wp-admin/admin.php"] [unique_id "UZZJ@tHsRz8ADUolCVMAAAAV"]

Share this post


Link to post
Share on other sites

Posted · Report post

The only thing i can find on google is that the page is taking too long to load.

 

You can get mod_security turned off per folder, depends how they have it setup.

Share this post


Link to post
Share on other sites

Posted · Report post

So the site itself is taking too long? 

The mod security thing is what I started out with. They said Mod_security is set for the entire server and they can't change it for one folder. Have you ever heard of that? I don't know what else to tell them to do.

 

Thanks for your help on this.

Share this post


Link to post
Share on other sites

Posted · Report post

Simon, do you think if I broke up the three facebook modes into three separate sections, it would fix it because each section would have fewer options?

Share this post


Link to post
Share on other sites