Jump to content


Photo
Featured Picture Boxes

chrome jitter in featured boxes



Best Answer ryanvarley , 14 May 2013 - 09:47 PM

hi. I have another question.

 

She has nine pages that I want to use as the 9 home boxes, and then have them link to that page.

 

can I pull pages into here?

 

 

You can use boxes, but if i understand you just want to pull page titles and featured images in like posts?

 

This was on the roadmap as a feature along with custom post types, pages should be super easy to implement, customs post types are a little harder. I will try and add this for you tomorrow.

 

 

hm. I am getting some jitter for sure. right now I have a bunch of boxes that don't have a hover and when they are hovered over, things start moving.

 

http://www.lynneheff...eries-excerpts/

 

Yeah i see it (but only on windows with chrome), its the standard mode that has the issue, i think its a webkit bug which hopefully i can find a solution for on my end. I'll look at this tomorrow to. 

Go to the full post


  • Please log in to reply
14 replies to this topic

#1 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 04:12 AM

hi. I'm close to pulling the trigger on Featured Picture Boxes but as I look at the demo site in chrome I see the images jitter and move a pixel or two when I hover over.

 

this looks about perfect otherwise but I  know I'd be hearing it from the client if they noticed the movements.

 

is this a known issue? if its cleared up I'm in.

 

thanks,



#2 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 14 May 2013 - 12:25 PM

ah yeah i see it, probably minor css, ill look at it today. Thanks for the report.



#3 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 01:28 PM

ok cool. thanks



#4 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 14 May 2013 - 02:12 PM

Hi i believe i have fixed this. it was a webkit bug in which the type of rendering changes for a hover effect. Can you verify this is fixed on the demo?



#5 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 02:33 PM

hi. its still doing it on mine. I cleared my cashe. I'm on Version 27.0.1438.7 m and it says I'm up to date.

 

its like a 1 pixel left or right shift on the main big ones, but the text stays put.

 

the little ones on the right though, the image stays fine but the text moves down a couple pixels on mouseover.



#6 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 14 May 2013 - 03:10 PM

OK it looks like a combination of 2 bugs, the one i fixed was very minor and it works perfectly on my mac now but on windows it is quite a noticeable jitter!

 

Again ill look at this in depth soon. Thanks



#7 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 04:52 PM

I went and bought it this morning anyway.

 

I love it! and its not jittering on my site in chrome...

 

http://www.lynneheff...rrante.com/new/

 

 

What I really like and appreciate is how easy you made it to use. Having a drop down box for the categories is so much nicer than making the user go hunt and peck for ID's.

 

really happy with this. 



#8 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 14 May 2013 - 05:40 PM

Thanks, i think the jitter only happens in the standard mode where the opacity changes and even then it seems variable. Glad you like it! - i had it almost complete for nearly 8 months before i got round to finishing and releasing so im happy its been well received but annoyed i didn't do it sooner.

 

Thats a very nice implementation of it aswell - it works well with the pictures and your site style, can i use it as a screenshot? And maybe when its live link to it from my site as a featured boxes 'in the wild'?



#9 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 06:09 PM

yeah that'd totally be fine. we're probably going to go live tomorrow.



#10 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 09:25 PM

hi. I have another question.

 

She has nine pages that I want to use as the 9 home boxes, and then have them link to that page.

 

can I pull pages into here?

 

my only other idea is to make posts for each page and then use that post and on click have the post redirect to the page I want.

 

but that is inelegant.



#11 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 09:40 PM

hm. I am getting some jitter for sure. right now I have a bunch of boxes that don't have a hover and when they are hovered over, things start moving.

 

http://www.lynneheff...eries-excerpts/



#12 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 14 May 2013 - 09:47 PM   Best Answer

hi. I have another question.

 

She has nine pages that I want to use as the 9 home boxes, and then have them link to that page.

 

can I pull pages into here?

 

 

You can use boxes, but if i understand you just want to pull page titles and featured images in like posts?

 

This was on the roadmap as a feature along with custom post types, pages should be super easy to implement, customs post types are a little harder. I will try and add this for you tomorrow.

 

 

hm. I am getting some jitter for sure. right now I have a bunch of boxes that don't have a hover and when they are hovered over, things start moving.

 

http://www.lynneheff...eries-excerpts/

 

Yeah i see it (but only on windows with chrome), its the standard mode that has the issue, i think its a webkit bug which hopefully i can find a solution for on my end. I'll look at this tomorrow to. 



#13 imagineutopia

imagineutopia

    Advocate

  • Members

  • 276 posts
  • LocationKansas City
  • Country: Country Flag

Posted 14 May 2013 - 09:57 PM

cool. thanks!



#14 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 15 May 2013 - 02:21 PM

If you consider this topic resolved, please click the "mark solved" button. Otherwise, let us know how we can help. :)



#15 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 16 May 2013 - 10:25 PM

Hey, to keep you updated i am working on the post feature tomorrow along with this jitter fix. I might not release the Post feature straight away as i may end up changing the pannel to support even more post types at the same time so if you email me at ryanjvarley@gmail.com i can send you a copy that supports it before its fully released.

 

The jitter fix will hopefully be solved at the same time but since im not 100% about the cause or fix i can't be certain. Thanks!







Also tagged with one or more of these keywords: Featured Picture Boxes