Jump to content


Photo
- - - - -

Reader – strange gray bar won't go away

Reader

Best Answer eglashcreative , 09 May 2013 - 04:27 PM

Thanks again James - you were a great help. Here's what finally worked:

 
.page-id-xx .pl_reader_container, .reader-content {
	background: none !important;
}

Thanks again! Marked as solved.

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 eglashcreative

eglashcreative

    Advanced Member

  • Members

  • 49 posts
  • LocationTulsa, Oklahoma, USA
  • Country: Country Flag

Posted 08 May 2013 - 06:26 PM

Hi there -

 

[I tried posting this in the Store Products forum - but it was unresponsive and just led me back to the forum page each time]

 

Please Login or Register to see this Hidden Content

 

You will notice a gray bar at the bottom of the Reader. I can't figure how this got there, but I will say a few things:

  • It goes away if I remove the last few questions;

  • It was there before I did all my CSS tweaks;

  • There doesn't seem to be a selector related to it, so I'm going to guess that it's a result of Settings.

Any ideas out there? Thank you!



#2 James B

James B

    Advocate

  • Moderators
  • 4978 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 08 May 2013 - 09:37 PM

Hi there,

 

Both seem to be releated to the content-pad within the reader section from looking at your site/code.  The reader content-pad seems to have a negative margin of -25 px which is why it appears above the sidebar area and not in alignment.

 

The grey bar seems to be coming from the minimum height set in the reader css -

Please Login or Register to see this Hidden Content

if the content inside doesn't fill that area and more, then you'll need to adjust with css to stop the grey bar displaying.



#3 eglashcreative

eglashcreative

    Advanced Member

  • Members

  • 49 posts
  • LocationTulsa, Oklahoma, USA
  • Country: Country Flag

Posted 09 May 2013 - 01:29 AM

Thanks so much, James. I fixed the padding issue - thanks for that tip. 

 

But I'm having trouble figuring a good way to globally fix the problem, instead of fixing min-height for each FAQ. Also, if you look at the third question (with the map), it clears the min-height requirement, but the gray bar remains on the Questions content-pad.

 

Again, all help truly appreciated. 



#4 James B

James B

    Advocate

  • Moderators
  • 4978 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 09 May 2013 - 02:10 AM

Hi there,

 

Looking at the demo its the same kinda situation -

Please Login or Register to see this Hidden Content

 

From what I can see from you site, it looks like you can either remove the padding at the bottom of the readernav -

Please Login or Register to see this Hidden Content

 

Or extend the background color for the readernav down to the bottom to cover the gap should there be a situation where the content goes past the last question box, I'd just colored it that shade of blue to demonstrate etc,

Please Login or Register to see this Hidden Content



#5 eglashcreative

eglashcreative

    Advanced Member

  • Members

  • 49 posts
  • LocationTulsa, Oklahoma, USA
  • Country: Country Flag

Posted 09 May 2013 - 04:27 PM   Best Answer

Thanks again James - you were a great help. Here's what finally worked:

Please Login or Register to see this Hidden Content

Thanks again! Marked as solved.







Also tagged with one or more of these keywords: Reader