Archived

This topic is now archived and is closed to further replies.

  • 0

Accordions Accordion Arrow not working on IE8

Question

Posted · Report post

Hi,

I have a screen capture to show the arrows are not showing up on IE8. Instead of the arrows the code f0da shows. Can you tell me how to fix this please.

On my Firefox the icon is also missing- this seems to be a recent thing.

 

Thanks!

http://www.c22marketing.com/employment-opportunities/

 

 

post-18235-0-23848000-1367928696_thumb.j

Share this post


Link to post
Share on other sites

8 answers to this question

Posted · Report post

HI Ellen,
 
After 3 hours of more searching and testing, I think I found a solution. There are two things that need to be done to fix the FONT AWESOME to display correctly in both IE8 and Firefox.
 
ADD TO CSS FILE:
[codesyntax]

 
@font-face {
font-family:FontAwesome;
src:url(http://netdna.bootstrapcdn.com/font-awesome/2.0/font//fontawesome-webfont.eot?#iefix) format('eot'), url(http://netdna.bootstrapcdn.com/font-awesome/2.0/font//fontawesome-webfont.woff) format('woff'),
url(http://netdna.bootstrapcdn.com/font-awesome/2.0/font//fontawesome-webfont.ttf) format('truetype'),
url(http://netdna.bootstrapcdn.com/font-awesome/2.0/font//fontawesome-webfont.svg#FontAwesome) format('svg'); font-weight:400;font-style:normal;
}
 
[/codesyntax]

 

ADD TO .htaccess file:

[codesyntax]

 

<FilesMatch ".(ttf|otf|woff)$">
    Header set Access-Control-Allow-Origin "*"
</FilesMatch>
 
 [/codesyntax]

 

 
I'm not an expert at this but these two things seemed to have worked for me. Hopefully it will for others as well.

Share this post


Link to post
Share on other sites

Posted · Report post

I don't know why it is affecting your sites but hasn't come up as an issue for others. There might be someone else though that has this problem and your solution can help them.

I'm using font awesome that is loaded with Pagelines and I'll double check that I am loading it correctly.

Thanks again for posting what worked to get the icons displaying properly.

Sent from my iPad using Tapatalk HD

Share this post


Link to post
Share on other sites

Posted · Report post

Accordion icons are still not working. I would really appreciate insight as to why they are not showing properly.

Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

I have alerted the developer of this topic.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I just got notified of your problem with the icons not working with Accordions in IE8 and Firefox.  The icons are using Font Awesome and work with IE8 and Firefox so something else is going on.

 

First, it looks like you are using the Base child theme. Let's activate the Pagelines Theme and see if the icons show properly. If they do then it might be something in the child theme. We will have to investigate further to see what is causing the issue.

 

If the icons still are displaying wrong then it might be a plugin conflict. Disable all plugins and then see if the icons show. If they do, reactivate one plugin at a time till you find the one that makes the icons not show properly.

 

Let me know your results.

 

Ellen

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

The Accordion Section is a third party product, which we are unable to provide support for. Therefore, I have moved your topic into the correct forum, where the sections developer will be able to respond your issue.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Danny.

Where is this forum so that I can make sure I can find the update/reply. Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Ellen,

I just ran into this problem again on another site. I de-activated all plugins - no change. I changed to the framework theme - no change.

 

I have looked online for possible solutions but have not been able to find proper articles related to this issue yet.

Any ideas on what could be going wrong? - I think it might be related to the Font Awesome.

Share this post


Link to post
Share on other sites