Jump to content


Photo
- - - - -

Accordion shortcode not working


Best Answer Danny , 03 May 2013 - 08:21 AM

OK, you're using PageLines Framework 2.3.3, I recommend you perform a backup and then update to the latest version, which is 2.4.1.

 

If this doesn't resolve your issue, I suggest disabling all non-PageLines plugins and see if that resolves your issue.

Go to the full post


This topic has been archived. This means that you cannot reply to this topic.
18 replies to this topic

#1 quinntinm†

quinntinm

    Super Member

  • DMS Subscriber†
  • 177 posts

Posted 03 May 2013 - 07:41 AM

Hi there.

I have tried some shortcode i found on the pagelines site but it just doesn't seem to work.

 

[pl_accordion name="accordion"][pl_accordioncontent name="accordion" number="1" heading="Tile 1" open="yes"]

Content 1

[/pl_accordioncontent]

 

[pl_accordioncontent name="accordion" number="2" heading="Title 2"]

<img class="pl-imageframe" src="" alt="" />

[/pl_accordioncontent]

 

[/pl_accordion]

 

 

 

 

Is there something i need to install first?

 

 

Thanks.

 

 



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 19770 posts

Posted 03 May 2013 - 07:49 AM

Hi,

 

Can you provide a link to the site in question and also where have added the accordion code ?



#3 quinntinm†

quinntinm

    Super Member

  • DMS Subscriber†
  • 177 posts

Posted 03 May 2013 - 08:14 AM

Please Login or Register to see this Hidden Content

 

I have added it into the main text area of the page.



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 19770 posts

Posted 03 May 2013 - 08:21 AM   Best Answer

OK, you're using PageLines Framework 2.3.3, I recommend you perform a backup and then update to the latest version, which is 2.4.1.

 

If this doesn't resolve your issue, I suggest disabling all non-PageLines plugins and see if that resolves your issue.



#5 quinntinm†

quinntinm

    Super Member

  • DMS Subscriber†
  • 177 posts

Posted 13 May 2013 - 08:36 AM

Wow, i thought this would be a real pain in the you know what, but i found it first plugin.

It seems the conflict was with "Sponsors Carousel" by

Please Login or Register to see this Hidden Content

 

 

whew.



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 19770 posts

Posted 13 May 2013 - 08:53 AM

Thanks for informing us the issue has been resolved, I would recommend using our Carousel section instead of the plugin.



#7 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts

Posted 31 May 2013 - 01:44 PM

Hi Danny,

I have the same problem.

on this page

Please Login or Register to see this Hidden Content

the accordion shortcode doesn't work.

I update to 2.4.2 version and try to disabling all plugins but it doen's still work



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 31 May 2013 - 02:30 PM

Hi Benz, could you paste the code you used? Its very likely there's some missing operand.



#9 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts

Posted 31 May 2013 - 02:36 PM

Hi Rob, thanks for your reply.

This is my code:

 

 

[pl_accordion name="SLK-POINT"]

[pl_accordioncontent name="SLK-POINT" number="1" heading="+ ABRUZZO"] elenco sedi [/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="2" heading="+ BASILICATA"] elenco sedi [/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="3" heading="+ CALABRIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="4" heading="+ CAMPANIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="5" heading="+ EMILIA-ROMAGNA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="6" heading="+ FRIULI VENEZIA GIULIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="7" heading="+ LAZIO"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="8" heading="+ LIGURIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="9" heading="+ LOMBARDIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="10" heading="+ MARCHE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="11" heading="+ MOLISE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="12" heading="+ PIEMONTE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="13" heading="+ PUGLIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="14" heading="+ SARDEGNA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="15" heading="+ SICILIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="16" heading="+ TOSCANA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="17" heading="+ TRENITNO ALTO ADIGE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="18" heading="+ UMBRIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="19" heading="+ VENETO"]elenco sedi[/pl_accordioncontent]

[/pl_accordion]



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 31 May 2013 - 02:49 PM

You have breaks in the code.

If you wraps the code in [pl_raw] tags it will strip out the breaks like this

Please Login or Register to see this Hidden Content



#11 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts

Posted 31 May 2013 - 02:58 PM

If I set open="yes" on each field the accordion is all open on my page.

I try to copy the example code of this page

Please Login or Register to see this Hidden Content

and it doesn't work too.



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 31 May 2013 - 03:27 PM

Okay, remove the open="yes" and wrap the whole code in pl_raw.



#13 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts

Posted 31 May 2013 - 04:07 PM

It still not working :(
 



#14 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 31 May 2013 - 05:34 PM

Pesaro

 

if you create a new admin level user for robert@pagelines.com, I'll take a look as soon as I can.



#15 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts

Posted 31 May 2013 - 05:54 PM

I just created it and you should have received the mail with credentials.

Thanks!!!!



#16 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 31 May 2013 - 06:00 PM

Nothing yet.



#17 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 31 May 2013 - 06:14 PM

Hi,

 

There is nothing wrong with the shortcode.  There must be a bad plugin or some bad CSS in your site. I copied your code and tested it on my own site. See this example.

 

Please Login or Register to see this Hidden Content

 

Try deactivating the non-PageLines plugins to see if the problem resolves.



#18 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts

Posted 01 June 2013 - 08:07 AM

Ok, I solve it.

For everybody who will have the same problem, it was a conflict with a javascript code that was set on
Pagelines > Site Option > Custom code > Headerscripts Code

 

Thanks a lot to Rob for your help.



#19 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 01 June 2013 - 01:29 PM

No problem!