Archived

This topic is now archived and is closed to further replies.

  • 0

Sign up page issues


Question

Posted · Report post

I recently decided to enable registration and after trying to use Register Plus Redux to customize my signup page I noticed the signup page was broken. It works with Twenty Twelve but not with Pagelines or the child theme "Transparency". I made a few failed attempts to fix the issue and hence I am here.

 

Here's the pertinent information:

 

Have you had a looked through the docs? Yes. No results found.
Have you searched the forum? Found a couple questions but not enough relevance.
Have you tried disabling plugins? Disabled all plugins ... issue persists.

Remember to include as much information about your technical issue as possible for example:
Website URL: http://relijon.org/demo/wp-signup.php
Framework Version: 2.4.1 (Transparency Child Theme)
WordPress Version: 3.5 MU
Plugins in Use: Currently none.
Server/Host: LAMP VPS
Screenshots: http://relijon.org/demo/wp-signup.php
Details: I tried in multiple browsers with no success.

PLEASE disable any cache plugins and purge any cached pages, we CANNOT help you if all we can see is a cached page. DONE :)

Share this post


Link to post
Share on other sites

13 answers to this question

Posted · Report post

The stylesheet isn't loading the right content.

 

I suspect that this snippet from your custom code is causing the problem, as it hides all the bits and pieces that make your page work:

#content,
#postloop,
#sb_primary,
#footer,
#twitter,
#simple_nav {
  visibility: hidden;
}
1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

If check the page for Register Plus Redux, you'll see in the right hand column that 3 out of 8 people are reporting it broken. That's always a bad sign for integration with other themes, particularly ones that are not themes but frameworks, where the underlying software is more complicated than Twenty Twelve.

 

It has mixed reviews.

 

I'd recommend using something like s2Member instead, which is a better product.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for the tip, but I currently do not have Register Plus Redux enabled.

Share this post


Link to post
Share on other sites

Posted · Report post

Have you re-saved the Permalinks?

Share this post


Link to post
Share on other sites

Posted · Report post

Yes. I just resaved the Permalinks which is set to %post%. Same issue so far.

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you Rob for the fresh eyes. :) I'm going to check that out now.

Share this post


Link to post
Share on other sites

Posted · Report post

I'd recommend validating your custom CSS in the "By direct input" tab here: http://jigsaw.w3.org/css-validator/

 

It's a good way to make sure you have no CSS coding errors, but you should also do a re-read to check for mistakes. Happens to the best of us.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for your help and I almost done ... I am still trying to figure out why the menu is still showing up. Any quick clues?

Share this post


Link to post
Share on other sites

Posted · Report post

I'm not sure. You may want to check the custom code, and also make sure you've set up the menu correctly.

Share this post


Link to post
Share on other sites

Posted · Report post

It seems someone has given you some bad advice about hiding things and using display:none;

 

See this:

<div style="display:none"><img style="display:none" src="http://relijon.org/demo/wp-content/plugins/neat-skype-status-pro/images/simple (very big Button)/0.png"/><img style="display:none" src="http://relijon.org/demo/wp-content/plugins/neat-skype-status-pro/images/simple (very big Button)/1.png"/><img style="display:none" src="http://relijon.org/demo/wp-content/plugins/neat-skype-status-pro/images/simple (very big Button)/2.png"/><img style="display:none" src="http://relijon.org/demo/wp-content/plugins/neat-skype-status-pro/images/simple (very big Button)/3.png"/><img style="display:none" src="http://relijon.org/demo/wp-content/plugins/neat-skype-status-pro/images/simple (very big Button)/4.png"/><img style="display:none" src="http://relijon.org/demo/wp-content/plugins/neat-skype-status-pro/images/simple (very big Button)/5.png"/><img style="display:none" src="http://relijon.org/demo/wp-content/plugins/neat-skype-status-pro/images/simple (very big Button)/7.png"/></div>

It's very bad to hide or use display:none on everything, as nothing will show.  I'd scrap all those references to display:none and verify all code sources where you customized to make sure you've not hidden anything else.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for your help. I realized that a particular JS was not enqueued properly for the registration page. :) I think the issue is 90% resolved. I am going to do a little more coding and get back to you.

Share this post


Link to post
Share on other sites

Posted · Report post

Okay!  We'll be here!

Share this post


Link to post
Share on other sites

Posted · Report post

I got things working but I will be abandoning Register Plus Redux. Thanks for your help.

Share this post


Link to post
Share on other sites