Jump to content


Photo
- - - - -

Sign up page issues

signup

Best Answer Rob , 29 April 2013 - 10:28 PM

The stylesheet isn't loading the right content.

 

I suspect that this snippet from your custom code is causing the problem, as it hides all the bits and pieces that make your page work:

 
#content,
#postloop,
#sb_primary,
#footer,
#twitter,
#simple_nav {
  visibility: hidden;
}
Go to the full post


  • Please log in to reply
13 replies to this topic

#1 ccowell

ccowell

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 29 April 2013 - 09:47 PM

I recently decided to enable registration and after trying to use Register Plus Redux to customize my signup page I noticed the signup page was broken. It works with Twenty Twelve but not with Pagelines or the child theme "Transparency". I made a few failed attempts to fix the issue and hence I am here.

 

Here's the pertinent information:

 

Have you had a looked through the docs? Yes. No results found.
Have you searched the forum? Found a couple questions but not enough relevance.
Have you tried disabling plugins? Disabled all plugins ... issue persists.

Remember to include as much information about your technical issue as possible for example:
Website URL:

Please Login or Register to see this Hidden Content


Framework Version: 2.4.1 (Transparency Child Theme)
WordPress Version: 3.5 MU
Plugins in Use: Currently none.
Server/Host: LAMP VPS
Screenshots:

Please Login or Register to see this Hidden Content


Details: I tried in multiple browsers with no success.

PLEASE disable any cache plugins and purge any cached pages, we CANNOT help you if all we can see is a cached page. DONE :)



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 April 2013 - 10:09 PM

Hi,

 

If check the page for Register Plus Redux, you'll see in the right hand column that 3 out of 8 people are reporting it broken. That's always a bad sign for integration with other themes, particularly ones that are not themes but frameworks, where the underlying software is more complicated than Twenty Twelve.

 

It has mixed reviews.

 

I'd recommend using something like s2Member instead, which is a better product.



#3 ccowell

ccowell

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 29 April 2013 - 10:10 PM

Thanks for the tip, but I currently do not have Register Plus Redux enabled.



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 April 2013 - 10:15 PM

Have you re-saved the Permalinks?



#5 ccowell

ccowell

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 29 April 2013 - 10:18 PM

Yes. I just resaved the Permalinks which is set to %post%. Same issue so far.



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 April 2013 - 10:28 PM   Best Answer

The stylesheet isn't loading the right content.

 

I suspect that this snippet from your custom code is causing the problem, as it hides all the bits and pieces that make your page work:

Please Login or Register to see this Hidden Content


  • ccowell likes this

#7 ccowell

ccowell

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 29 April 2013 - 10:35 PM

Thank you Rob for the fresh eyes. :) I'm going to check that out now.



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 April 2013 - 10:38 PM

I'd recommend validating your custom CSS in the "By direct input" tab here:

Please Login or Register to see this Hidden Content

 

It's a good way to make sure you have no CSS coding errors, but you should also do a re-read to check for mistakes. Happens to the best of us.



#9 ccowell

ccowell

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 29 April 2013 - 11:00 PM

Thanks for your help and I almost done ... I am still trying to figure out why the menu is still showing up. Any quick clues?



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 April 2013 - 11:07 PM

I'm not sure. You may want to check the custom code, and also make sure you've set up the menu correctly.



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 April 2013 - 11:15 PM

It seems someone has given you some bad advice about hiding things and using display:none;

 

See this:

Please Login or Register to see this Hidden Content

It's very bad to hide or use display:none on everything, as nothing will show.  I'd scrap all those references to display:none and verify all code sources where you customized to make sure you've not hidden anything else.



#12 ccowell

ccowell

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 29 April 2013 - 11:27 PM

Thanks for your help. I realized that a particular JS was not enqueued properly for the registration page. :) I think the issue is 90% resolved. I am going to do a little more coding and get back to you.



#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 April 2013 - 11:37 PM

Okay!  We'll be here!



#14 ccowell

ccowell

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 30 April 2013 - 03:22 AM

I got things working but I will be abandoning Register Plus Redux. Thanks for your help.







Also tagged with one or more of these keywords: signup