• 0
Sign in to follow this  
Followers 0

No Scroll In Twinshot


Question

62 answers to this question

  • 0

Posted · Report post

Hi everyone, I've just heard from our developer team that this error was due to a conflict in the javascript and has been fixed in our latest update of Twinshot (1.1.3) which has gone live today. Please update the latest edition.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

Check the URLs of your videos, they should all look like this:

http://vimeo.com/57574896

and not like this:

http://vimeo.com/video/57574896?wmode=transparent

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I checked my urls, done of them say /video/numbers, they are like the first.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Can you disable all non-PageLines plugins and see if this resolves your issue, can you also provide a screenshot showing all your video URLS please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm afraid I don't have any non pagelines plugins. The url screen grabs would take 9 pages. Will the list work?

 

2013 Reel
https://vimeo.com/57574896

Lords of War
https://vimeo.com/65001841

No Reservations Promo
http://www.youtube.com/watch?v=G9RbZ-j2GcY

Google Nexus 4
https://vimeo.com/57171586

Art21: Diana Al-Hadid
http://vimeo.com/46885446

PRPS Brand Video
https://vimeo.com/27831650

AllSaints SXSW Showcase
http://www.youtube.com/watch?v=8XIjT9it4nI

Wordsworth
http://www.youtube.com/watch?v=h5V9rNRvIGk

Abbe May
http://www.youtube.com/watch?v=oLGfeVH-ftI

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You say you have no non-PageLines plugins installed, but when I view your site, I can see .js files loaded that are for the Nextgen Gallery plugin, this isn't a PageLines plugin, please disable all non-PageLines and see if this resolves your issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

That gets installed with pagelines, but i deleted next gen. i have the same issue. thank you for your help.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Nextgen gallery does not get installed with PageLines Framework, it is a third party plugin and the only way this plugin can be installed, is if you have installed it yourself.

 

OK, I will try to recreate your issue, as soon as I have more information, I will reply here.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Those plugins are recommended plugins, but they're still third party and you have to install them manually, as they do not come included with PageLines Framework.

 

Twin Shot is a video gallery and doesn't support images. If you wish to have an image gallery you can use a third party plugin such as Nextgen Gallery. I was simply asking you to disable all non-PageLines plugins to see if the issue with TwinShot was resolved, which it wasn't so Nextgen Gallery wasn't the cause.

 

I will try to recreate your issue and reply here when I have more information.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I dont mean an image gallery in pagelines i mean a gallery with next gen. thank you for your help.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

To clarify, are you searching for a third party gallery plugin that will work in conjunction with NextGen?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No. It would be cool if I could use Next Gen and Twinshot at the same time, but if I can't it is much more important to get the scroll function working in twinshot. Do you know how I might do that?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Jesse,

 

There have been issues in past where NextGen images were called by other plugins or functions, resulting is problems related to javascript or jquery.  It's best not to try to combine them, avoiding the risk of causing a crash or other problems. 

 

The basic problem is that when an image is supplied to the post by NextGen, it's not actually in the post. The image is added by code, rather than 'associated' with the post by WordPress.  Then, when any plugin, section or other element tries to pull or call that image from the post, it doesn't see the association, or the media library image, resulting in the inability to display the image. This sets up a series of PHP processes that can literally crash a server by overloading resources.

 

NextGen itself is not a problem. It's simply the mixing of things that doesn't work.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok cool thanks for that info...very through... totally get it.

 

kind of disappointing but be as it be... i deleted nextgen and twinshot still does not have a scroll function at johnmarton.com. what can i do to get scroll functionality?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Jesse,

 

My apologies. I was thinking of another of our products, so I do apologize.

 

The scroll should be based on how many entries are made.  So I'm not sure why it's not working.

 

You've set the number of slides and followed all the documentation here, I presume:  http://support.pagelines.me/docs/sections/twinshot/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yeah its in the settings... 9 is the max. There are 9 videos in the demo. I have 8 videos. You can not view the 8th however because the scroll function does not work. How can I have the scroll function work?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Try adding a 9th, just to see if that makes it happen.  It could be a bug.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I apologize. The limit is 10. I tried 8, 9, and 10 videos. However the scroll function will not work. Any other ideas on how to fix this problem?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there,

 

I would image there's something conflicting which is preventing the scroll feature, looking in the source code I can see that it's using the class for no scroll bar. You can try and override this by using the following custom code. Just paste into Pagelines>site options>custom css, under the body tag.

 

.mCSB_container {
    overflow: scroll;
    width: auto;
}

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I did that, still wont work. i deleted every plugin besides Select Pagelines Sections and Pagelines Customize. ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, it looks like you've added #body in front of the line of code. You won't need to do that, just paste in as below. The body tag is already at the top of your custom css box in the default install.

.mCSB_container {
    overflow: scroll;
    width: auto;
}

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yeah neither worked. I changed it to your code without the extra body tag. still no luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0