Archived

This topic is now archived and is closed to further replies.

  • 0

Body of site becomes left-aligned when changed to Framework


Question

Posted · Report post

Hi,

 

I am the manager of Cleantech Blog (www.cleantechblog.com).

 

I've been using iBlogPro4 successfully for a couple years. Everything is fine now with the body in the center. When I switch to new Framework (v2.4.1) with and without the iBlogPro, the body becomes left aligned. All pages including the homepage becomes left aligned.

 

Even with all of the plugins turned-off, the alignment goes to the left. I've tried specifying float:center in the css for the body but nothing seems to work. 

 

Are there other options I can try?

 

Thank you,

Frank

Share this post


Link to post
Share on other sites

11 answers to this question

Posted · Report post

You have the following custom CSS, which is causing the issue, remove the CSS and it will resolve your issue.

 

 

#page, #site #page, #site #dynamic-content, #dynamic-content {
float: center;
display: block;
}
#page {
max-width: 960px;
float: center;
}

There is no such property as float: center (this is invalid CSS) and the max-width: 960px on #page is causing the alignment issue. Therefore, this issue is related to your custom CSS and not PageLines.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Frank,

 

I'm not seeing anything inappropriate or flushed left on the site in Firefox.

 

Is there some particular condition in which this is happening, or some other browser you're using?

 

It could be that the browser's cache is caught at a particular point in the loading of the page. Did you try clearing the browser cache?

 

See the screenshot below:

post-6-0-12176000-1367154871_thumb.jpg

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Rob,

 

Thanks for your assistance. The screenshot below shows what it looks like when we switch to iBlogPro5 with the Framework.

 

Frank

post-8967-0-65836800-1367157400_thumb.pn

Share this post


Link to post
Share on other sites

Posted · Report post

I'm not sure why this is happening.

 

iBlogpro4 is a deprecated theme, so I'm unsure of its settings.

 

Unfortunately, there may be some CSS or something that's causing this.

 

Are you making the migration to iBlog5 permanent?

Share this post


Link to post
Share on other sites

Posted · Report post

We'd like to switch to iBlog5 but we will keep using iBlog4 until a fix can be found.

Share this post


Link to post
Share on other sites

Posted · Report post

Is there any Custom CSS?

 

As you're using an old theme, do you have any outdated plugins? I'd recommend deactivating all except the ones from PageLines' Store.

Share this post


Link to post
Share on other sites

Posted · Report post

Even when I de-activate all of the plugins, the result is the same.

Share this post


Link to post
Share on other sites

Posted · Report post

It's possible the installation of PageLines Framework did not complete properly.

 

I'd recommend FTPing into the site and deleting wp-content/themes/pagelines  and reinstalling it, manually.

 

To do this, login to your Launchpad account, download the latest version and unzip the file to your desktop.  You'll see a folder named pagelines.

 

Once you've deleted the pagelines folder from wp-content/themes, just upload the new pagelines folder on your desktop to replace it. Any settings will be stored in the database, so there will be no need to repeat that step.

Share this post


Link to post
Share on other sites

Posted · Report post

That did not seem to work. Still aligning to the left when framework or iblogpro5 is used.

 

Is there a simple css fix for this?

Share this post


Link to post
Share on other sites

Posted · Report post

I don't know. If you'd like to email me admin level credentials, I'll go in and take a look at things to see what I can find.

 

Send them to robert@pagelines.com

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Danny. That seems to do the trick!

 

Frank

Share this post


Link to post
Share on other sites