Archived

This topic is now archived and is closed to further replies.

  • 0

Image with caption

Question

Posted · Report post

Hi,

 

I don't get support at the pagelines forum because I use a premium theme. I have to ask it here they say.

 

 

1) when I insert an image with title, alt and caption, the title from the image will dissapear, only alt and caption is showing. I have to click on the image again and add the title manually again. Is this a known problem?
2) When I already have an image in the post and change it with adding a caption, it will have a lot more white space on top. Is this also a known problem? It makes working in the editor not really easy.

Hope somebody can help me.

Kind regards,

 

Willem

 

Share this post


Link to post
Share on other sites

7 answers to this question

Posted · Report post

1. In Wordpress 3.5 the title attribute was removed from images, see here - http://core.trac.wordpress.org/ticket/18984

 

2. What I was saying is that the Visual editor is the first thing I disable when I install Wordpress on sites I am working on.

 

So you will need to ask Wordpress support how to add the title attribute back or add the title attribute yourself.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I am not quite sure what you're referring to when you say "I don't get support at the pagelines forum because I use a premium theme. I have to ask it here they say.". Can you go into greater detail please.

 

1. Not sure what you mean when you say the title will disappear ?

 

2. PageLines has no control over the Wordpress editor. The Wordpress visual editor is very poor and is one of the first things I do once I have installed Wordpress.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, I'm really sorry. I ment at the WP forum, see here: http://wordpress.org/support/topic/image-with-caption?replies=11#post-4118143

I don't get support there because I use a premium theme.

 

1) The situation is, when I upload an image I fill in title, alt and caption. When I upload this image into a post, the title will not be visible in the HTML. I discovered this is with all images (also the images I only use title and alt). I am suprised about this because I was thinking this was copied from the title I fill in at the image. However, the title is not that important so I can't bother > but is this new that WP makes the title go away when inserting an image?

 

If this is new, then I don't understand they still use title form normal text links, because the value there is also minimal... 

 

2) OK, that is what I told the people over there also (check the link in this post). What do you mean with 'one of the first thing I do'? If you have any tips on how to improve I wil be very happy.

 

Kind regards,

 

Willem

Share this post


Link to post
Share on other sites

Posted · Report post

No problem Willem.  I was too.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, I think it's a good thing they removed the title attribute. Thanks for the link.

Just wondering when they will remove the title attribute for normal text links, it has no (SEO) benefit at all, the effect it has in different browsers are not the same.

 

Kind regards,

 

Willem

Share this post


Link to post
Share on other sites

Posted · Report post

Willem, I wish we knew. But that's a question for the folks at WordPress.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Rob, I understand ;-). I was just speaking out my thoughts, not questioning ;-).

Share this post


Link to post
Share on other sites