Jump to content


Photo

WooCommerce plug in & Pagelines Nav + menus

woocommerce

Best Answer ellenmva , 21 April 2013 - 08:31 PM

Hi Keith,

 

For the Navbar you do need to set what menu for it to use.  Go to Site Options --> Navbar and scroll down to Navbar and Fixed Navbar Menus and select a menu.  Also, with the Woocommerce Menu Cart you can put that in the Navbar, just select the same menu for both.

 

If setting the menu for the Navbar doesn't solve the issue then deactivate the WooCommerce for Pagelines Plugin. Are the child pages still there?  How about if you deactivate the Woocommerce Menu Cart?

 

Let me know what your results are.

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 keithmagvacom

keithmagvacom

    Advocate

  • Members



  • 377 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 April 2013 - 09:25 PM

Hi Folks

 

I am having some problems with WooCommerce plug in and would appreciate some input for the community. I installed said plugin and as expected it create the various additional pages. These are now appearing the in the Nav element of the site, however I would prefer that the not particularly cart and checkout. 

 

Is there any way of removing these? 

 

I am hoping to use a plug in called woocommerce menu cart in the bar as an alternative but this requires a nav menu to be defined. I have tried defining a new menu for my primary navigation but none of the primary nav appeared on the nav bar (the menu items under What we do did appear)! (see image)

 

The site is not live yet, however I am using the latest build of Framework, Wordpress and all plugins. For the purposes of testing I have the BrandNav AND the NavBar temporally added to the headed.

[attachment=962:Nav Bars.tiff][attachment=963:NavBar1.tiff]



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 April 2013 - 01:30 PM

Hi Keith,

 

It seems that the settings for your site still allow default page addition to the menus.

 

Two key settings are very easy to apply that should fix this, and one basic step.

 

First, go to Dashboard > PageLines > Site Options > Header And Footer > uncheck Use Child Pages for Secondary Nav?

 

Next, go to Dashboard > Appearance > Menus and uncheck "Automatically add new top-level pages"

 

The step needed is to add pages manually through Dashboard > Appearance > Menus. This ensures that pages do not appear which are not desired and allows you to control levels and menu levels.

 

When you said "I have tried defining a new menu for my primary navigation but none of the primary nav appeared on the nav bar (the menu items under What we do did appear)!", did you make sure the menu you created or edited was the one selected under "Theme Locations" as the Primary Website Navigation?


  • keithmagvacom likes this

#3 keithmagvacom

keithmagvacom

    Advocate

  • Members



  • 377 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 21 April 2013 - 01:42 PM

Hi Rob, thanks for the reply and the clarifications. That helps and something I had missed before...

 

 

When you said "I have tried defining a new menu for my primary navigation but none of the primary nav appeared on the nav bar (the menu items under What we do did appear)!", did you make sure the menu you created or edited was the one selected under "Theme Locations" as the Primary Website Navigation?

 

Yes I selected the menu under the theme locations as the primary nav. It returned only the pages that were under the "What we do" button for the Nav bar. Didn't have the same problem in the BrandNav section.



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 April 2013 - 02:29 PM

Keith, may I see this site live?



#5 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 April 2013 - 04:34 PM

So, I think the NavBar is somehow picking up the secondary nav and I'm not sure why.  It's not set anywhere I can see, except that in Dashboard > PageLines > Site Options > Header And Footer under Secondary Nav - Use Child Pages.

 

I'm going to bump this up to the developer's queue, since the WooCommerce integration plugin is in place and may have some influence here.



#6 ellenmva

ellenmva

    Advocate

  • Members

  • 332 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 21 April 2013 - 08:31 PM   Best Answer

Hi Keith,

 

For the Navbar you do need to set what menu for it to use.  Go to Site Options --> Navbar and scroll down to Navbar and Fixed Navbar Menus and select a menu.  Also, with the Woocommerce Menu Cart you can put that in the Navbar, just select the same menu for both.

 

If setting the menu for the Navbar doesn't solve the issue then deactivate the WooCommerce for Pagelines Plugin. Are the child pages still there?  How about if you deactivate the Woocommerce Menu Cart?

 

Let me know what your results are.



#7 keithmagvacom

keithmagvacom

    Advocate

  • Members



  • 377 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 21 April 2013 - 08:40 PM

 

For the Navbar you do need to set what menu for it to use.  Go to Site Options --> Navbar and scroll down to Navbar and Fixed Navbar Menus and select a menu.  Also, with the Woocommerce Menu Cart you can put that in the Navbar, just select the same menu for both.

 

 

Thanks Ellen

 

Its been one of those days (or weekends I should say). Never set the menu in the Site Options. That has sorted the problem. 

 

Thank you ever so much. 

 

 

So, I think the NavBar is somehow picking up the secondary nav and I'm not sure why.  It's not set anywhere I can see, except that in Dashboard > PageLines > Site Options > Header And Footer under Secondary Nav - Use Child Pages.

 

I'm going to bump this up to the developer's queue, since the WooCommerce integration plugin is in place and may have some influence here.

 

Thanks Rob for your help also. It turned out to be a very simple setting in the end that I had not activated...

 

Really appreciate the help.







Also tagged with one or more of these keywords: woocommerce