Jump to content


Photo
SaleBar

Salebar Plugin + Premise = Blank Page!



  • Please log in to reply
7 replies to this topic

#1 francescofornaro

francescofornaro

    Advanced Member

  • Members
  • 39 posts
  • Country: Country Flag

Posted 16 April 2013 - 08:31 PM

Hi All,

 

since I installed Premise Plugin on my website, I found that Salebar plugin, if active, causes some troubles.

Basically, any landing page created with Premise is... blank. You need to deactivate Salebar Plugin and the page appears. 

 

Have you any solution for this issue? I don't want to stop using Salebar, but I want to use Premise too :)

 

Thank you so much!



#2 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 16 April 2013 - 08:52 PM

Hi there,

 

Unfortunately some third party plugins will clash with the Framework or some sections depending on certain code/scripts being used. Have you managed to speak with the plugin author regarding this? If so have they been able to advise which part is causing the problem? Unfortunately we're unable to test premium plugins directly so any additional information they can provide might be able to help us issue a work around or fix.



#3 francescofornaro

francescofornaro

    Advanced Member

  • Members
  • 39 posts
  • Country: Country Flag

Posted 16 April 2013 - 08:56 PM

Hi,

 

Premise support ask me to contact the plugin developer. Could I do anything to help you to communicate about this issue? Maybe the plugin author should be in touch with Premise support team and try to fix it.

 

Thanks.



#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 April 2013 - 09:01 PM

Blank as in php error blank?

 

If so enable WP_DEBUG in wp-config.php and let us know the error produced.



#5 francescofornaro

francescofornaro

    Advanced Member

  • Members
  • 39 posts
  • Country: Country Flag

Posted 16 April 2013 - 09:07 PM

Sure,

 

I will post debug output the next monday, since I'm leaving for business right now. Thank you!



#6 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 16 April 2013 - 09:14 PM

No problem, we'll leave this thread open for you so just paste in the error information when you're back.



#7 francescofornaro

francescofornaro

    Advanced Member

  • Members
  • 39 posts
  • Country: Country Flag

Posted 18 April 2013 - 09:27 AM

Hi all,

 

I couldn't paste the error information so far (I'm still OOO), but this is the email that Premise developers sent to me. Hope it can be useful:

 

 

I think the issue with the plugin is that it is using functions specific to the theme without first checking to see if those functions are available. Premise disables the theme though so the functions are not available. This isn't really good coding practice.

I work a lot with Genesis and have a half dozen or more plugins for it. I have learned to use a special check to see if the Genesis functions are available before using them. My method adds practically no overhead, in fact it can be a good deal more efficient, and it makes my code 100% safe even if Genesis gets disabled.

I don't know if it will work for a pagelines plugin but I would think there would be a way to do it. I load everything on an init hook. Genesis has its own init hook (genesis_init) so nothing in my plugin runs unless Genesis is active because I use that hook. The plugin developer should do that or a similar method to make sure their code is safe to run.

 



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16897 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 18 April 2013 - 09:31 AM

I will bring your reply to our developers attention and see what they suggest.


  • francescofornaro likes this





Also tagged with one or more of these keywords: SaleBar