Archived

This topic is now archived and is closed to further replies.

  • 0

BuddyPress 1.7 theme auto support


Question

Posted · Report post

Hi, 

 

The new buddypress 1.7 is out and their new code to work with every theme is there without the need of the BP template pack anymore.

 

Because of the BP template pack some new buddypress plugins are not working. In order to use buddypress my theme needs some code in functions.php from what i could understood from buddypress support, something that looks like this for those still using template pack (needed for the pagelines to work with buddypress):

 

function fixes_buddydrive_for_template_pack() {

    add_theme_support( 'buddypress' );

}
add_action( 'after_setup_theme', 'fixes_buddydrive_for_template_pack' );

 

or needs to be fixed with this info

 

http://bpdevel.wordpress.com/2013/02/25/bp-theme-authors-make-sure-your-theme-registers-buddypress-support/

 

 

Can pagelines be updated with these things for future?

 

Maybe team working already on this, maybe is wrong for me to post and ask this but, wanted to let you guys know as i am using pagelines with buddypress and came across this problem.

Share this post


Link to post
Share on other sites

10 answers to this question

Posted · Report post

Hi there,

 

I'll forward this on to the core team for info. They're currently looking into the Buddypress update this week, at the moment as we stand both the template pack and the integration plugin are required to make it work correctly.

 

If that code does the job, I'm sure they'll add it to the core on the next update.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Hi

I am about to upgrade a site from 1.6.x -> 1.7 and would be greatful to know when PageLines will support the upgrade regarding the new templating system. I did a quick test on a dev install by disabling the integration plugin and template pack.

The pages seem to render with the archive template so before the BuddyPress content Viewing archives for "" is displayed.

Is there a hook to remove the 'Posts info section' for just the BP pages as a temporary workaround?

Share this post


Link to post
Share on other sites

Posted · Report post

ok here are some tries using the recommended plugins. 

 

your suggestions are welcome...

 

http://screencast.com/t/ZEFqj86Ucm

 

is it: just forget about it and use twenty twelve?

 

really should i even bother to try to get PL and BuddyPress to play friendly with one another?

Share this post


Link to post
Share on other sites

Posted · Report post

Hello 

 

Please could you create a new topic with all the information and we will be able to help you out 

Share this post


Link to post
Share on other sites

Posted · Report post

Hi

I am about to upgrade a site from 1.6.x -> 1.7 and would be greatful to know when PageLines will support the upgrade regarding the new templating system. I did a quick test on a dev install by disabling the integration plugin and template pack.

The pages seem to render with the archive template so before the BuddyPress content Viewing archives for "" is displayed.

Is there a hook to remove the 'Posts info section' for just the BP pages as a temporary workaround?

 

I have this going on right now. Buddypress 1.7.2, did you ever get this resolved?

Share this post


Link to post
Share on other sites

Posted · Report post

You can remove that by using CSS.

Share this post


Link to post
Share on other sites

Posted · Report post

I also tested today if buddypress  can be used without the template pack and no, not possible. THe buddypress 1.7 theme integration is not yet available for pagelines it seems. I am waiting for this one also.

1 person likes this

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.