Jump to content


Photo
- - - - -

Strict standards error on library.options.php on line 119

xampp

  • Please log in to reply
9 replies to this topic

#1 fsline

fsline

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 11 April 2013 - 04:19 PM

Hello,

 

I am recieveing an error similar to the one described in this forum post - 

Please Login or Register to see this Hidden Content

 

Here is a screenshot -

Please Login or Register to see this Hidden Content

 

I am only seeing the error in my windows development environment using xampp 1.8.1 and PHP 5.4.7. 

 

I only get the error when I initialize the pagelines framework theme. I am manually setting my site url in the wp-config.php file. 

 

Any suggestions?

 

 

Thank you. Love the framework!

 

--Michael



#2 fsline

fsline

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 11 April 2013 - 04:37 PM

I also tried to disable output of strict standards per this error: 

Please Login or Register to see this Hidden Content



#3 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 April 2013 - 04:48 PM

I also tried to disable output of strict standards per this error: 

Please Login or Register to see this Hidden Content

 

As i mentioned in the other thread, the error is fixed in our dev branch, the next version will include it.



#4 fsline

fsline

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 11 April 2013 - 05:01 PM

Any recommendations until the next version is released? Just trying to understand what causes it so I can find a temporary work around. 



#5 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 April 2013 - 05:24 PM

Im installing windows to try xampp.



#6 fsline

fsline

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 11 April 2013 - 05:35 PM

I was able to remove the error by disabling a plugin :-/

 

Any recommendations still appreciated



#7 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 April 2013 - 05:37 PM

Im installing windows to try xampp.

 

Please give me a chance.


  • fsline likes this

#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 April 2013 - 05:52 PM

Well i installed windows, and xampp and dont see any errors, i edited the config and changed error reporting to e_all and still nothing.

 

Exactly what plugin?



#9 fsline

fsline

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 11 April 2013 - 05:55 PM

Its a custom plugin that caused no errors in our production environment. 



#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 April 2013 - 05:59 PM

Well error reporting should always be turned off in production thats why.

 

What is the plugin supposed to be doing?







Also tagged with one or more of these keywords: xampp