Jump to content


Photo
Viewer

Doesn't respect HTTPS on wp-admin

https ssl

Best Answer beardedavenger , 11 April 2013 - 02:33 PM

changed to plugins_url was an oversight. updated.

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 CliffordP

CliffordP

    Advocate

  • Members


  • 451 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 11 April 2013 - 01:00 PM

In Google Chrome Inspector -> Console it displays this message twice on the PageLines Site Options page:
 

The page at https:// ... /wp-admin/admin.php?page=pagelines displayed insecure content from http:// ... /wp-content/plugins/viewer/icon.png.



#2 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 11 April 2013 - 01:13 PM

You'll have to bring this up to simon. There's nothing I can do about this from my end. Also, why do you need SSL for admin?

 

http://screencast.com/t/7E4yUHyv



#3 CliffordP

CliffordP

    Advocate

  • Members


  • 451 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 11 April 2013 - 02:11 PM

WP_PLUGIN_URL doesn't work with SSL. You should use http://codex.wordpre...nce/plugins_url

 

Like this: http://screencast.com/t/ha09sdQ868



#4 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 11 April 2013 - 02:21 PM

Cliff,

This is the code that we, as 3rd party developers use in our sections.

 

$this->icon.png

 

Bring it up to simon, there's nothing i can do about this.



#5 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 11 April 2013 - 02:33 PM

changed to plugins_url was an oversight. updated.



#6 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 11 April 2013 - 02:33 PM   Best Answer

changed to plugins_url was an oversight. updated.







Also tagged with one or more of these keywords: Viewer, https, ssl