Jump to content


Photo
- - - - -

Can't access Store or log in to account from Pagelines Menu

Store account

Best Answer Danny , 09 April 2013 - 12:12 PM

As I suspected, your debug mode shows the following settings are enabled on your server.

 

PHP User : Posix functions are disabled on this host!

PHP Safe Mode : Yes!
PHP Magic Quotes gpc : Yes (bad)
 
These are certainly the cause of your issue, especially safe mode, which has been deprecated as of PHP 5.3.0 and removed as of PHP 5.4.0. Therefore, you will need to contact your host provider and ask them to resolve the following. They can do this by upgrading your PHP version to 5.4.
Go to the full post


  • Please log in to reply
5 replies to this topic

#1 zhonghao

zhonghao

    Super Member

  • Members

  • 101 posts
  • Country: Country Flag

Posted 09 April 2013 - 09:19 AM

Hi, I have spent a few days swapping emails with Danny & Catrina via the Help email line and Danny suggested I now post onto the forum. I have been unable to login to my account or access the Store page from the WP-Pagelines Menu. Please refer to the following link for details. Thanks and regards, Richard. 

Please Login or Register to see this Hidden Content



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 13192 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 09 April 2013 - 09:40 AM

Hi Richard,


Can you provide both your server PHP info, as it is most likely server related i.e. security etc.. -

Please Login or Register to see this Hidden Content

 

A long with a link to the site in question and enable PL debug mode please, you can enable PL debug mode by going to PageLines > Site Options > Advanced.



#3 zhonghao

zhonghao

    Super Member

  • Members

  • 101 posts
  • Country: Country Flag

Posted 09 April 2013 - 12:07 PM

Hi Danny thanks for reply. the PL debug is enabled. The site is www.bodyworksasia.cn  Will send the php info later or tomorrow as now there seems to be something wrong with my server so can not upload the file as stated in the link you provided. Regards, Richard



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 13192 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 09 April 2013 - 12:12 PM   Best Answer

As I suspected, your debug mode shows the following settings are enabled on your server.

 

PHP User : Posix functions are disabled on this host!

PHP Safe Mode : Yes!
PHP Magic Quotes gpc : Yes (bad)
 
These are certainly the cause of your issue, especially safe mode, which has been deprecated as of PHP 5.3.0 and removed as of PHP 5.4.0. Therefore, you will need to contact your host provider and ask them to resolve the following. They can do this by upgrading your PHP version to 5.4.


#5 zhonghao

zhonghao

    Super Member

  • Members

  • 101 posts
  • Country: Country Flag

Posted 09 April 2013 - 12:26 PM

Interesting - Thanks. I talked about 'Safe mode' with the 'provider' before as mentioned in one of the emails via the help line (maybe it was you ... ?) He informed me that he would not change the PHP version as it is 'still new and untested.....' Maybe I will think about changing provider. I'll get back to him and see what happens now. Many thanks.



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 13192 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 09 April 2013 - 12:40 PM

No problem, happy to help. I have marked the topic as resolved, if you have further questions, let me know.







Also tagged with one or more of these keywords: Store, account