Jump to content


Photo
- - - - -

Help Installing the WP-PageNavi Pluggin


  • Please log in to reply
7 replies to this topic

#1 pspr

pspr

    Super Member

  • Members
  • 114 posts
  • Country: Country Flag

Posted 09 April 2013 - 12:47 AM

Hi guys I need some help installing the WP-PageNave pluggin. The instructions are really short but I cant seem to pass the first step. Im using the the Pagelines Framework 2.4.1 theme. I cant seem to find the next_posts_link() ..... I would appreciate any help I can get. Thank you.

 

Usage

In your theme, you need to find calls to next_posts_link() and previous_posts_link() and replace them.

In the Twentyten theme, it looks like this:

<div class="nav-previous"><?php next_posts_link( __( '<span class="meta-nav">&larr;</span> Older posts', 'twentyten' ) ); ?></div>
<div class="nav-next"><?php previous_posts_link( __( 'Newer posts <span class="meta-nav">&rarr;</span>', 'twentyten' ) ); ?></div>

You would replace those two lines with this:

<?php wp_pagenavi(); ?>

For multipart pages, you would look for code like this:

<?php wp_link_pages( ... ); ?>

and replace it with this:

<?php wp_pagenavi( array( 'type' => 'multipart' ) ); ?>

Go to WP-Admin -> Settings -> PageNavi for configuration.



#2 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 09 April 2013 - 12:58 AM

Hello there, you won't need to do that within Pagelines, the code and styles are already built in. Just have to install and activate the plugin. Make sure the pagination section is active on the template :-)

 

See

Please Login or Register to see this Hidden Content



#3 pspr

pspr

    Super Member

  • Members
  • 114 posts
  • Country: Country Flag

Posted 09 April 2013 - 01:15 AM

I see.. Thank you very much for your help. I just want to make sure I am understanding it. So the pagination section is active. But the reason why its not showing on my page is because I only have 8 postings. Correct? So after my 10th posting the WP-PageNavi Will appear. Is there any way I can configure that number?



#4 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 09 April 2013 - 01:19 AM

Yes you can, go to settings>reading and change the figure for 'blog page shows at most'.



#5 pspr

pspr

    Super Member

  • Members
  • 114 posts
  • Country: Country Flag

Posted 09 April 2013 - 01:25 AM

Beautiful. Thank you very much. And i have another question about my Css Style text in the dashboards/site options. Im not sure what i did.... but when i try to scroll down with the mouse... it does not work. so the only way I can scroll down in the css is if i click the text in the text box and hold the arrow key to scroll down... this started happening from yesterday.... once i forget and scroll with my mouse it scrolls back to the top again..... was wondering if you guys could help me with this problem..



#6 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 09 April 2013 - 01:42 AM

That's strange, I've not heard of that before. What changes did you make the day it started happening? Any new code placed in the css box? Any web developer extensions installed into the browser? Any new plugins installed?

 

I would say deactivate all third party plugins and test to see if it stops, deactivate any browser extensions, remove your css and resave, see if keeps happening. If it doesn't start re-activating each bit one by one to see where the problems coming from.



#7 pspr

pspr

    Super Member

  • Members
  • 114 posts
  • Country: Country Flag

Posted 09 April 2013 - 01:54 AM

definitly........ man I like the way you think. good stuff my man. ima troublshoot it like that. thanks again.



#8 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 09 April 2013 - 02:05 AM

You're welcome :-)