Jump to content


Photo
- - - - -

error message library.options.php on line 119

library.options.php

Best Answer Simon_P , 08 April 2013 - 08:23 PM

The original error

Strict Standards: Non-static method PageLinesTemplate::page_type_breaker()

 

Would be caused because (probably) you were using php 5.4 with strict standards and page_type_breaker() function was not set to public. Nothing at all to do with any plugin.

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 ingo68

ingo68

    Member

  • Members

  • 28 posts
  • LocationGermany
  • Framework Version:2.4
  • Country: Country Flag

Posted 08 April 2013 - 01:30 AM

I received the following error message (...i think it happened after the update of footer extras....)

 

Strict Standards: Non-static method PageLinesTemplate::page_type_breaker() should not be called statically in /homepages/33/d314378333/htdocs/demo/wp-content/themes/pagelines/includes/library.options.php on line 119

 

 

Website URL:

Please Login or Register to see this Hidden Content

Framework Version: Version 2.4.1
WordPress Version: Version 3.5.1



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 April 2013 - 09:06 AM

Hi,

 

Where is the location of this error ?

 

If you disable the Footer Extras, does the error disappear ?



#3 ingo68

ingo68

    Member

  • Members

  • 28 posts
  • LocationGermany
  • Framework Version:2.4
  • Country: Country Flag

Posted 08 April 2013 - 09:20 AM

Hi,

the location of this error is in footer area.

if I disable footer extras, I get no change. when I plugin "poppy" views, I get the same error

Please Login or Register to see this Hidden Content

. IE9 everything is displayed correctly.



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 April 2013 - 09:41 AM

When I view your site, I am not seeing any error in your footer ?

 

Please Login or Register to see this Hidden Content



#5 ingo68

ingo68

    Member

  • Members

  • 28 posts
  • LocationGermany
  • Framework Version:2.4
  • Country: Country Flag

Posted 08 April 2013 - 07:38 PM

errors found!
the Ultimate TinyMCE plugin vers 4.3.1.3 caused this error message.
after uninstall of TinyMCE again everything is ok.



#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 08 April 2013 - 08:23 PM   Best Answer

The original error

Strict Standards: Non-static method PageLinesTemplate::page_type_breaker()

 

Would be caused because (probably) you were using php 5.4 with strict standards and page_type_breaker() function was not set to public. Nothing at all to do with any plugin.



#7 ingo68

ingo68

    Member

  • Members

  • 28 posts
  • LocationGermany
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 April 2013 - 04:11 PM

Hi Simon,

many thanks for your note. you're right!!



#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 09 April 2013 - 04:32 PM

Do you need further assistance with this issue or did Simon's response help you resolve it?



#9 ingo68

ingo68

    Member

  • Members

  • 28 posts
  • LocationGermany
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 April 2013 - 04:38 PM

Hi Catrina,
Simon's response did much help me. thanks!



#10 bluecloud

bluecloud

    Advanced Member

  • Members
  • 44 posts
  • LocationHillegom
  • Framework Version:latest (always)
  • Country: Country Flag

Posted 16 August 2013 - 10:06 AM

After a recent update I got the same error messages. 

 

The function page_type_breaker() is declared as "public function" but i.m.o. it should be declared as "public static function" 

see: includes/class.template.php on line 96

Please Login or Register to see this Hidden Content



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 August 2013 - 06:32 PM

Please just copy the error here.  The link doesn't provide line numbers.