Jump to content


Photo

bbpress css to remove sidebar


Best Answer Rob , 08 April 2013 - 11:54 PM

Kev,

 

Scroll down on that edit page, and on the right do you see PageLines Section Control or something like that where you see an option with a check box where you can "Hide Primary Sidebar"?  If so, check it and save the page. If you're using the secondary and tertiary sidebars in your page, hide those as well, and save.

 

Make sure in your PlatformPro settings you've checked the option to Hide Sidebars when Empty.

 

See if that works.

Go to the full post


  • Please log in to reply
15 replies to this topic

#1 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 05 April 2013 - 02:01 PM

Hi,

 

I am looking for some advice with custom css to remove the sidebar from my bbpress forum, at the below location.

 

http://wolfhirschhor.../forum/general/

 

Any help much appreciated.

 

Regards,

 

Ross

 

 



#2 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 05 April 2013 - 03:59 PM

Have you tried adjusting the layout of the page in the Meta Settings at the bottom of the page editor?



#3 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 05 April 2013 - 06:30 PM

Thanks Jenny, but not sure I know what you're talking about. Is that in PageLines maybe? This site is using PlatformPro...

 

Also, the forum pages aren't visible in my 'Pages' area as they are created (dynamically?) by bbpress, as far as I can work out at least.

 

Any other ideas?

 

Thanks again,

 

Ross


Edited by kevinobrien, 05 April 2013 - 06:30 PM.


#4 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 05 April 2013 - 11:16 PM

Hi Ross,

 

Using the forum tab in the sidebar of the wp admin area you should be able to access the meta settings for the forum page.

 

See - http://screencast.com/t/MqtbC40wfs



#5 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 07 April 2013 - 11:01 PM

Thanks James, appreciate that but I don't have the Meta Settings options showing... Are you using PlatformPro or PageLines?

 

Cheers,

 

Ross



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17124 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 April 2013 - 09:01 AM

Hi,

 

I highly recommend you upgrade to PageLines Framework, which is compatible and supports bbPress. Something which Platform Pro does not since bbPress 2.x

 

However, here is the CSS that should change your forums layout to full width.

 

 

 
// Hides Sidebar
body.bbPress #sidebar-wrap {
display: none;
}

// Makes Forum full width
.bbPress #site #column-wrap, .bbPress #site #column-main {
width: 100% !important;
}
 


#7 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 08 April 2013 - 10:44 AM

Thanks Danny, much appreciated but doesn't seem to have done the trick...

 

I'll look seriously at making the jump to PL Framework.

 

Thanks again,

 

Ross



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 17124 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 April 2013 - 10:53 AM

Not sure why it hasn't worked for you, maybe a cache plugin ?

But code certainly does work.

 

http://cl.ly/image/2m2v330H291S

http://cl.ly/image/1F271i1K1m40



#9 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 08 April 2013 - 12:56 PM

Thanks again Danny, I did have W3 caching enabled but disabled it and still no dice. I tried putting the code in the custom code box, the bbpress.css file and the theme.css file within the theme directory - but no joy. Fairly confident I'm doing something entirely stupid...

 

Ross



#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 17124 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 April 2013 - 12:59 PM

I'm not seeing the custom CSS from above, being loaded at all on your site. Therefore, clear cache on W3 Cache and then disable the plugin, then see if that resolves the issue.


The only thing I can see in your custom CSS, is the following:

 


 

 
/* Custom CSS */


body{}
.blog #boxes{display:none}
.blog #feature{display:none}
.single-post #boxes{display:none}
.single-post #feature{display:none}
#feature #bbforum{display:none}
 

 



#11 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 08 April 2013 - 03:04 PM

Thanks Danny, cache cleared - plugin disabled - still no luck.

 

Can you see your code in my custom css now?



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 April 2013 - 08:33 PM

Hi Kevin,

 

Unfortunately, PlatformPro is now a deprecated product and many of us don't use it anymore. I concur with Danny, you should really upgrade promptly, as each WordPress update places your site at greater risk of crashing. No further updates to PlatformPro will be forthcoming, so if it crashes, we won't have a solution.

 

Meanwhile, PlatformPro does have Meta Settings on each page.  If you go to Dashboard > Pages and edit the pages where bbPress appear, scroll down to see PageLines Meta Settings.  If you do not see this option, please go to the top-right, click Screen Options.  A panel will descend and the first option should be PageLines Meta Settings. Make sure it is checked.  You just close the panel by clicking Screen Options again.  Scroll down, and the meta settings should appear. 

 

Thereupon, you should see under the General Page Setup tab the drop down list which allows you to make the page full width.  Select that, save the Page. Now, the bbPress page should be full width, without sidebar.  You may also, optionally, use the PageLines Sections Control Panel, on the edit page to "Hide Primary" sidebar (and/or any sidebars selected in your layout). Check that and save. 

 

Unfortunately, support for PlatformPro is extremely limited at this point.  Danny was also correct in saying that PlatformPro has not supported any bbPress since bbPress 2.x came out. There is a compatibility issue which is unsupported. The only solution is upgrading to PageLines Framework.



#13 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 08 April 2013 - 10:02 PM

Cheers Rob, point taken - we will be looking at making the switch at some point soon hopefully.

 

Incidentally, I still can see PageLines Meta Settings in either Dashboard > Pages or Page Settings...

 

Capture.JPG

 

 Thanks again,

 

Ross



#14 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 April 2013 - 10:08 PM

Ross, you're looking in the wrong place.  Click on a page, then click to edit the page.  The PageLines Meta Settings are not located in Dashboard > Pages but inside the individual page edit screen.



#15 kevinobrien

kevinobrien

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 08 April 2013 - 11:25 PM

Thanks Rob - but I was editing a page in that screen grab. Whether accessing from Dashboard > Pages > Edit or Edit direct from the page it takes you to the same place as far as I can see.

 

I think we must be looking at different versions of the theme or something. Thanks again for your help thus far, happy to put it to bed if we've hit a dead end.

 

Cheers,

 

Ross

 

Capture1.JPG


Edited by kevinobrien, 08 April 2013 - 11:30 PM.


#16 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 April 2013 - 11:54 PM   Best Answer

Kev,

 

Scroll down on that edit page, and on the right do you see PageLines Section Control or something like that where you see an option with a check box where you can "Hide Primary Sidebar"?  If so, check it and save the page. If you're using the secondary and tertiary sidebars in your page, hide those as well, and save.

 

Make sure in your PlatformPro settings you've checked the option to Hide Sidebars when Empty.

 

See if that works.