Jump to content


Photo
- - - - -

Can't change Page Options for Author Posts

bug Page Options Author page

  • Please log in to reply
36 replies to this topic

#1 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 08:05 AM

I'm trying to change the Page Options for Author Posts (I want to hide the primary sidebar). I change the options, click Save options (the blue button) and get the message "Base Theme settings saved - View your site". 

 

But it doesn't work. The options page reload with none off the options changed, and the changes doesn't take effect either. 

 

This is only an issue with Page Options for Author Posts, I can change all other Pages Options. 

 

I think this is a new issue after the latest Pagelines upgrade (I've changed this options before).

 

I've tried to disable all plugins, except the ones that are either from Wordpress.org (the ones that come with the installation, like Importer), from Pagelines or recommended by Pagelines, but that didn't change anything. 



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 08:22 AM

Hi,

 

I've just this moment gone to Page Options > Author Posts, hide the Branding section, Simple Nav section and hide the Primary Sidebar. I then save settings, visit my test blog, click the authors name on one of my posts and when the Author Posts page loads, there is no Branding, Simple Nav section active neither is the Primary Sidebar.

 

I am using the latest version of both Wordpress and PageLines Framework.



#3 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 08:27 AM

OK, so it seems like it is an issue with my site, not Pagelines. Any ideas for troubleshooting?

 

What could cause this?



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 08:33 AM

Usually, something like is caused by third party plugins. Therefore, I recommend you disable all plugins and see if this resolves your issue. If this doesn't resolve the problem, keep the plugins disabled and enable PageLines debug mode, it may be related to custom CSS or an issue with your server configuration.

 

You can enable PageLines debug mode by going to Wordpress Admin Dashboard > PageLines > Site Options > Advanced.

 

Also please provide a link to the site in question.



#5 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 08:42 AM

Site: 

Please Login or Register to see this Hidden Content

 

Disabling all plugins didn't solve this, but for some reason author sites returned as 404 when all plugins where disabled?

 

What does debug mode do? How do I use it to debug?



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 08:47 AM

Can you please keep all plugins disabled, as you currently have 27 active. Also, can you enable [post_author_posts_link] on your Posts Meta options, for testing purposes.



#7 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 08:53 AM

OK

 

The site is active, but I guess I can do with some hours of troubleshooting.



#8 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 08:56 AM

Half the site is now 404! Does disabling the Pagelines plugins do that?



#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 08:56 AM

Can you provide a screenshot of the sections that are active on:

 

PageLines > Drag & Drop > Page Template > Author

PageLines > Drag & Drop > Content Area > Author



#10 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 09:03 AM

screenshot-author-pagetemplate.jpg

 

and 

 

screenshot-author-contentarea.jpg



#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 09:19 AM

OK, I am not entirely sure as what is causing your author page issue but I think it may be related to your server. The reason I think this, is on your debug information you have the following:

 

PHP Magic Quotes gpc : Yes (bad)

 

Therefore, enable all your plugins again and reply here when you have done so.



#12 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 09:26 AM

All plugins enabled.



#13 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 09:29 AM

OK, is this now working as intended ?

Please Login or Register to see this Hidden Content



#14 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 09:42 AM

What do you mean by intended? It is working as it used to.



#15 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 09:43 AM

What is weird is that the sidebar is on the right side on this author page: 

Please Login or Register to see this Hidden Content

, while it is one the left side on all others.



#16 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 10:12 AM

The sidebar is on the left for me

Please Login or Register to see this Hidden Content



#17 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 10:15 AM

Sorry, I probably need more coffee. It is on the right on the others: 

Please Login or Register to see this Hidden Content



#18 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 10:17 AM

OK, please disable all non-PageLines plugins, you have WP Super cache, cache plugins should never be active when you're still working on your sites layout etc.. Cache plugins should be the last thing to activate and only do so when your site design has been completely finalised.



#19 attac

attac

    Super Member

  • Members
  • 132 posts
  • Country: Country Flag

Posted 04 April 2013 - 10:22 AM

Shouldn't be a problem for me with the cache as long as I'm logged in (WP Super cache doesn't cache for logged in-users), but it will of course affect you. I've disabled it now.



#20 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 April 2013 - 10:26 AM

Can you please disable all non-PageLines plugins please, like I mentioned above.







Also tagged with one or more of these keywords: bug, Page Options, Author page