Jump to content


Photo
- - - - -

Sub Menu Not Working


Best Answer davidvidgen , 03 April 2013 - 10:11 AM

I've managed to updated to PHP 5.3 - unfortunately, 5.4 isn't an option with my hosting provider.

 

I have multiple wordpress sites all running pagelines on the same hosting plan, so it was unlikely that Posix functions was the cause. The other sites did not have issues. 

 

I have found the root cause of the problem. I have had issues recently with the site being compromised with hidden title and meta descriptions etc. So I installed various plugins to try and prevent this again. I initially thought that the plugins were the cause, but as we know deactivating them was not solving the problem.  However, one of the recommendations to harden wordpress was to add the following to the .htaccess file:

 

RewriteRule ^(wp-includes)\/.*$ ./ [NC,R=301,L]

 

By removing this line of code it has resolved the issue.

 

This item can now be closed. 

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 davidvidgen

davidvidgen

    Member

  • Members

  • 14 posts
  • LocationBirmingham, UK
  • Framework Version:DMS 1.1.7
  • Country: Country Flag

Posted 03 April 2013 - 08:33 AM

Hi

 

Having a few difficulties with my site: davidvidgen.co.uk, the sub menu navigation has ceased working and none of the menus are displaying in mobile view on iphone 4. 

 

i have installed another wordpress theme and it works okay so it leaves me to think the issue is with the pagelines framework.

 

This is what I have done so far:

 

deactivated all plugins

deleted custom menu and rebuilt

checked that the Enable Drop Down Navigation? is ticked

made sure the fixed Navbar has the appropriate menu selected

I have checked the site in firefox, safari and chrome - all not working

 

Any other pointers will be much appreciated.

Attached Files



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 15680 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 03 April 2013 - 08:54 AM

Hi,

 

When I view your sites source, I can see the HTML for the drop down menus. However, you have a number of js errors on your site, which could be the cause of the issue, these are either caused by plugins or bad code.

 

Therefore, can you please disable all non-PageLines plugins and any custom scripts/code you may have added. Also, enable PageLines debug mode, which you can enable by going to PageLines > Site Options > Advanced.



#3 davidvidgen

davidvidgen

    Member

  • Members

  • 14 posts
  • LocationBirmingham, UK
  • Framework Version:DMS 1.1.7
  • Country: Country Flag

Posted 03 April 2013 - 08:59 AM

Hi Danny

 

All disabled and debug mode activated.



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 15680 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 03 April 2013 - 09:11 AM

According to your debug information your host for whatever reason has disabled Posix functions, this is enabled by default in PHP. Therefore, I recommend you contact your host and ask them to enable this. As this may be the cause of the issue.

 

Also, in your debug info, you have the following:

PHP Magic Quotes gpc : Yes (bad)

When contacting your host, I recommend you ask them to either resolve this or update your PHP to version 5.4, as Magic Quotes was deprecated in 5.3 and remove completely in 5.4.



#5 davidvidgen

davidvidgen

    Member

  • Members

  • 14 posts
  • LocationBirmingham, UK
  • Framework Version:DMS 1.1.7
  • Country: Country Flag

Posted 03 April 2013 - 10:11 AM   Best Answer

I've managed to updated to PHP 5.3 - unfortunately, 5.4 isn't an option with my hosting provider.

 

I have multiple wordpress sites all running pagelines on the same hosting plan, so it was unlikely that Posix functions was the cause. The other sites did not have issues. 

 

I have found the root cause of the problem. I have had issues recently with the site being compromised with hidden title and meta descriptions etc. So I installed various plugins to try and prevent this again. I initially thought that the plugins were the cause, but as we know deactivating them was not solving the problem.  However, one of the recommendations to harden wordpress was to add the following to the .htaccess file:

 

RewriteRule ^(wp-includes)\/.*$ ./ [NC,R=301,L]

 

By removing this line of code it has resolved the issue.

 

This item can now be closed. 



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 15680 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 03 April 2013 - 10:13 AM

Happy to hear you issue has been resolved and thank you for informing us, we appreciate it.