Archived

This topic is now archived and is closed to further replies.

  • 0

Next Gen Gallery messed up - Problem with theme compatability


Question

Posted · Report post

Hi,

 

I've noticed my clients page is messed up slightly which pulls images from next gen gallery. See here:

 

http://www.businessinteriors.co.uk/portfolio/clients-office-design-inspiration/

 

When I was trying to find the issue I ran the compatability check in the nextgen plugin and it said there is this problem:

 

 

  • Check theme compatibility

    Missing the call to wp_head() in your theme, contact the theme author

     

I have the latest wordpress updates, framework is up to date and I use a child/base theme.

 

Thanks,

 

James

 

Share this post


Link to post
Share on other sites

11 answers to this question

Posted · Report post

Ok...I fixed it by using this custom css:

 

 

.ngg-galleryoverview {overflow: visible}
code {padding: 0px; border: 0px;}
 
I'm not sure why it should have stopped working....or indeed if that final bit of code has messed anything else up...but its working at the moment...

Share this post


Link to post
Share on other sites

Posted · Report post

I tried this solution placing<?php wp_head(); ?> in the custom code header....but didnt work

Share this post


Link to post
Share on other sites

Posted · Report post

Hi James,

How are you adding the images to your page?

As I have just created a gallery, added it to my page and there is no issue.

 

http://cl.ly/image/3s3228373m1u

Share this post


Link to post
Share on other sites

Posted · Report post

I've just put in short code....is working fine before...this is my short code:

 

[nggallery id=5 template=caption]

 

Any ideas? Anything to do with that wp_head() call thing? 

Share this post


Link to post
Share on other sites

Posted · Report post

I tried this solution placing<?php wp_head(); ?> in the custom code header....but didnt work

Dont place PHP in the Javascript headers box!

 

Hi,

 

I've noticed my clients page is messed up slightly which pulls images from next gen gallery. See here:

 

http://www.businessinteriors.co.uk/portfolio/clients-office-design-inspiration/

 

When I was trying to find the issue I ran the compatability check in the nextgen plugin and it said there is this problem:

 

 

  • Check theme compatibility

    Missing the call to wp_head() in your theme, contact the theme author

     

I have the latest wordpress updates, framework is up to date and I use a child/base theme.

 

Thanks,

 

James

PageLines Framework includes the call to wp_head(). Every theme HAS to, otherwise it just wont work! NextGen is just looking in the wrong place thats all.

 

You didnt really mention what exactly is wrong with your site.

Share this post


Link to post
Share on other sites

Posted · Report post

Well if you click on the link to the page that I'm talking about I think it's clear what the problem is. For some reason the images are not lining up (right side top) and at the right hand side the images  are missing the right edge. I've changed page widths, nothing happens  Basically Nextgen gallery isn't working properly on the page like it used too...have a look at the page I'm referring to here:

 

http://www.businessinteriors.co.uk/portfolio/clients-office-design-inspiration/

 

I've tried de-activating plug-ins and nothing fixes it. In the overview section of next gen gallery I clicked the "check compatibility" button and the error message came up 

 

Missing the call to wp_head() in your theme, contact the theme author

 

Is that any clearer? Thanks.

Share this post


Link to post
Share on other sites

Posted · Report post

Making some progress...if I hide "overflow: hidden" using css...that brings the "right hand" side back....but it still doenst explain why the alderking logo is lower than the others...also their are some mystery additions to the bottom...

Share this post


Link to post
Share on other sites

Posted · Report post

Framework includes the call to wp_head(), so not sure why that error is popping up. What mystery additions are you referring to?

Share this post


Link to post
Share on other sites

Posted · Report post

Ok making some more progress have been tweaking css using firefly...and have "fixed" the alignment issues (the fifth logo was dropping down and I had some weird new mini boxes at the end)

 

It seems to be in some new code after next gen, see here my screenshot...I unchecked the border and padding css here and it fixed it...but what code do I put in to permanently fix it in custom css? And do you know why it stopped working in the first place?!

 

http://screencast.com/t/e7xeXCAFOEX

Share this post


Link to post
Share on other sites

Posted · Report post

Okay, awesome. Do you want this thread to be kept open or marked as resolved?

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Yup resolved thanks

Share this post


Link to post
Share on other sites