Jump to content


Photo

Remove Excerpt from Feature Box


Best Answer Danny , 02 April 2013 - 05:59 AM

Hi,

 

To remove the text only, you will need to use the following code.

 

 

 
#site .fexcerpt {
display: none;
}

However, in future, I recommend using Firebug or your browsers built-in web dev tools and inspect the element you wish to customise, to find the correct code.

 

For assistance visit our custom CSS documentation - http://support.pagelines.me/docs/customization/custom-css/

Go to the full post


  • Please log in to reply
12 replies to this topic

#1 jasonlioh

jasonlioh

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Framework Version:1.6.0
  • Country: Country Flag

Posted 01 April 2013 - 04:30 PM

I would like to remove the "Excerpt" and tiny line before that in my feature box. Any idea how to do it? 

 

You can check the screenshot below. 

 

http://jasonlioh.com...ne/Untitled.png



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 01 April 2013 - 06:04 PM

To get rid of that line, please add this code to Site Options > Custom Code > Custom CSS:

 
#page #feature_slider .text-bottom .fcontent .fheading {background: none !important;}

To get rid of the excerpt, just don't enter any text for the slide.



#3 jasonlioh

jasonlioh

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Framework Version:1.6.0
  • Country: Country Flag

Posted 02 April 2013 - 01:28 AM

The code didn't work. 

I didn't type anything in the excerpt option. The feature box automatically grabs the first 55 words as the excerpt. 



#4 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 02 April 2013 - 02:43 AM

Hi there, yes that will be generated by the first words of the excerpt. You can use css to hide the text on the slider though, in firebug or chrome look for an area classes fcontent or textbottom like in Catrina's example above. Change the display property on either of those classes to display:none to see which gives the effect to hide the text you wanted.



#5 jasonlioh

jasonlioh

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Framework Version:1.6.0
  • Country: Country Flag

Posted 02 April 2013 - 02:55 AM

Base on Inspect Element, it should be div.ftext, but I don't think my codes are working. 
 

#page #feature_slider .text-bottom .fcontent .fheading #ftext {background: none;}

 

Advice?



#6 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 02 April 2013 - 04:02 AM

If you want to hide the text it would be

 

 
.ftext {display:none;}
 


#7 jasonlioh

jasonlioh

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Framework Version:1.6.0
  • Country: Country Flag

Posted 02 April 2013 - 05:06 AM

Ah, that code works alright, but it also removes the "Continue Reading..." link which then renders the Feature Box useless as it doesn't link back to the post. 

 

:(

 

Any idea or if it's possible to remove the excerpt but keep the "Continue Reading..." button? 

 

From Inspect Element, I think it should just the "p" but under ftext.  

 

 

 

http://jasonlioh.com... 1.04.08 PM.png


Edited by jasonlioh, 02 April 2013 - 05:19 AM.


#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 15702 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 02 April 2013 - 05:59 AM   Best Answer

Hi,

 

To remove the text only, you will need to use the following code.

 

 

 
#site .fexcerpt {
display: none;
}

However, in future, I recommend using Firebug or your browsers built-in web dev tools and inspect the element you wish to customise, to find the correct code.

 

For assistance visit our custom CSS documentation - http://support.pagelines.me/docs/customization/custom-css/



#9 jasonlioh

jasonlioh

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Framework Version:1.6.0
  • Country: Country Flag

Posted 02 April 2013 - 06:15 AM

Hi Danny, 

 

Your codes work! Thanks. Any idea about that tiny line that appears in between the title and excerpt? 

 

Thank you. Shall check that out later. 



#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 15702 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 02 April 2013 - 06:37 AM

Unfortunately, our staff aren't actually allowed to provide custom CSS and have already gone beyond what we are allowed by providing the above custom CSS. I recommend you inspect your site using Firebug or your browsers built-in web dev tools, to find the correct code.

 

For assistance visit our custom CSS documentation - http://support.pagel...ion/custom-css/



#11 jasonlioh

jasonlioh

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Framework Version:1.6.0
  • Country: Country Flag

Posted 02 April 2013 - 06:46 AM

Danny, alright, noted with thanks! 

 

Thank you very much for going beyond what you could to help me out. 



#12 jasonlioh

jasonlioh

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Framework Version:1.6.0
  • Country: Country Flag

Posted 02 April 2013 - 01:52 PM

I found the code: 
 
 
.fheading {
    background: url("../images/hl-vert.png") repeat-y scroll right top transparent;
    float: left;
    padding: 0 10px;
    width: 33%;
}

 

And the only way I know of to remove the line is by deleting the image file from the theme file. 

 

I tried this but it didn't work. 

 

 
#fheading {
padding: 0 10px;
float: left;
width: 33%;
}

 

 



#13 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 03 April 2013 - 12:45 AM

In your last code, you didn't include the background line. If you added the background line and changed it to display:none that will remove the image :-)