Jump to content


Photo
Filtering

"Filtering" Section on Bilingual Websites



Best Answer Sourena , 16 April 2013 - 05:43 AM

Thank you Ellen. The plugin works perfectly now!

 

@Jenny: This issue is resolved.

Go to the full post


  • Please log in to reply
22 replies to this topic

#1 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 27 March 2013 - 04:26 AM

I am trying to use on a "Filtering" Section on bilingual website. Everything works fine except the words "Show All", "Prev" and "Next" could not be translated.

How can I fix that?



#2 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 27 March 2013 - 01:02 PM

Hi,

 

It's something I have to fix in Filtering.  You can change the Show All phrase in options but ideally Filtering should translate that phrase. I should have an update later today or tomorrow for you.  Will let you know when I do.

 

Ellen



#3 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 27 March 2013 - 01:07 PM

Thank you!



#4 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 27 March 2013 - 05:05 PM

I pushed an update and it should work.  I tested it with Transposh and did have to set the option for pretty permalinks otherwise the pagination doesn't work.

 

Any problems let me know.

 

Ellen



#5 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 27 March 2013 - 08:43 PM

Ellen,

 

Transposh is not the right plugin to test this. To translate a wordpress themes or plugin you need to do certain things described in this page:

http://wp.tutsplus.c...es-and-plugins/

 

I am not sure how you can localize a Pagelines "section" but there should be a way to include "Show all", "Prev" and "Next" in Pagelines' "mo" and "po" files.



#6 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 27 March 2013 - 11:30 PM

Yes, my code is like what is in the tutorial except that Pagelines creates the .pot file in the section folder. When I created the section I didn't have the Show All, Prev and Next localized.  They are now localized and part of the filtering.pot file.

 

So, those phrases should now translate.

 

Ellen 



#7 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 28 March 2013 - 03:05 AM

Where is the section folder located? I searched the themes folder but I cannot find it among the sections.



#8 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 28 March 2013 - 12:22 PM

The folder is in wp-content/plugins/pagelines-sections/filtering. There should be a filtering.pot file there.  If it is not, let me know and I will investigate further.

 

Ellen



#9 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 29 March 2013 - 11:17 AM

I wanted to see if the phrases translated for you with the adjustments I made to the section.  If not, I want to help get it working for you. Please let me know if you need further assistance.

 

Ellen



#10 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 29 March 2013 - 01:09 PM

Thanks. I have a problem with my server. I downloaded the POT file and translated it. Then I tried to upload the files but the server does not allow me to upload them because the permissions are set to 755 and I cannot change it from my FTP client software. I have to take care of this issue first, then I can see if the translation works.



#11 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 29 March 2013 - 02:35 PM

Okay, let me know. Good luck with your server.



#12 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 29 March 2013 - 05:58 PM

I finally uploaded the tranlstion files but now it seems the section works incorrectly. Check this page and try to navigate through pages 1 to 6:

http://shahrefarang.com/new/en/

 

It seems the content doesn't change sometimes. I click on "next" or page numbers but the page only reloads the same content.



#13 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 29 March 2013 - 08:01 PM

Hmm, it's seems to have to do with the /new being there.  The page changes but the pagination on the bottom doesn't change.  I'm going to setup a test site that is in a sub-folder of root and see if I can replicate the issue.  

 

Again, sorry that it is not working properly.  Will try and get it fixed as soon as possible.

 

Ellen



#14 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 29 March 2013 - 08:30 PM

Thanks for your quick response and your effort to fix this!



#15 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 29 March 2013 - 08:35 PM

I setup a test site like yours and it worked fine using a subfolder, whew!  I think the culprit is Views, it is loading a pagination script and I think that is conflicting with the pagination in Filtering.  Could you try deactivating Views and see if the problem still exists?  

 

Let's hope that's the issue.  Then we can figure out how to handle it.

 

Ellen



#16 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 29 March 2013 - 08:47 PM

THat is strange. Because before the update it was working fine even though Views was active.

 

I just disabled Views. But the problem is still there. My plugins are:

 

 
Contact Form 7
 
FancyBox for WordPress
 
Pagelines Sections
 
Post Types Order
 
WPML Media
 
WPML Multilingual CMS


#17 ellenmva

ellenmva

    Advocate

  • Members

  • 256 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 30 March 2013 - 01:55 AM

I have access to WPML but it will take me a bit to set it up. Before I do, if you could do me one more favor and disable all plugins except pagelines sections and see if the pagination still isn't advancing since it is happening in both the Persian and English. If it works, just reactivate the WPML plugin and see if it doesn't work again. If it doesn't work without WPML activated then something else is going on. If it is only broken with WPML then I'll need to know how you have things setup. Another thing to try is going into wp-config.php and set Debug to true and see if you are getting any error messages on the page. Ellen Sent from my iPad using Tapatalk HD

#18 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 30 March 2013 - 04:45 AM

"Filtering" had no problem before the update. It was working fine with all the other plugins installed.

 

I disabled all the plugins (except Pagelines sections) and it still had the same problems: No "Prev", additional "/", and the problem with "Next".



#19 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 03 April 2013 - 03:15 PM

Please let us know if you still need assistance with this issue otherwise I will close the topic in 7 days. Thanks!



#20 Sourena

Sourena

    Advocate

  • Members

  • 563 posts
  • LocationWilliamstown, MA
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 03 April 2013 - 03:57 PM

I still need assistance. I need some time to test it again.







Also tagged with one or more of these keywords: Filtering