Jump to content


Photo
- - - - -

Long Wait and Connect Times to Server

speed windows

  • Please log in to reply
4 replies to this topic

#1 jamiewalden

jamiewalden

    Super Member

  • Members
  • 109 posts
  • Country: Country Flag

Posted 26 March 2013 - 03:02 PM

Hey guys, 

 

We've recently updated from Platform Pro to Pagelines and I'm noticing significantly slower page loading. 

 

When I run a test on pingdom (

Please Login or Register to see this Hidden Content

), it's showing that my "connect" (notated in blue) and "wait" (notated in yellow) are pretty high. I don't know if that means we need to reconfigure something on our server or what. (Note: We are on a Windows box (IIS 7) as our team builds .asp software applications. So that configuration may not be ideal, but we didn't have speed issues on Platform Pro. Please also note that since our tech team is all asp - and I'm only self-taught enough to be dangerous as my background is in design - we aren't incredibly versed in php and all things wordpress.)

 

Also in that pingdom report, it's showing i am getting a 404 on the stlye.css file, which is in the  themes folder where it should be. So not sure why that's the case.

 

We are currently using a child theme. We were using the pagelines customize plugin for our css, which seemed to deliver better speed for some reason, but did not work with IE8 on Windows XP. I have another thread on that.

 

We tried adding this to the functions.php file in the customize plugin: add_filter( 'render_css_posix_', '__return_true' );

Got that from a forum thread, but our site is still slow. 

 

Here is our site:

Please Login or Register to see this Hidden Content

 

Any help would be immensely appreciated.



#2 jamiewalden

jamiewalden

    Super Member

  • Members
  • 109 posts
  • Country: Country Flag

Posted 26 March 2013 - 03:44 PM

The style.css error is resolved. Was a typo. Site speed is still the same though.



#3 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 26 March 2013 - 05:51 PM

That css 404 is from your child theme css file, your importing a file with no css in it ;)

 

You page has a lot of images ISS is doing the best it can serving 45 http requests.

 

My advice:

 

Install wp-super-cache to server static pages.

signup for maxcdn and offload all your images/css/js requests to the cdn.



#4 jamiewalden

jamiewalden

    Super Member

  • Members
  • 109 posts
  • Country: Country Flag

Posted 26 March 2013 - 06:47 PM

Tried wp super cache and I think it was conflicting with the caching settings we have already. I may explore using max cdn or outsourcing our hosting wpengine.



#5 James B

James B

    Advocate

  • Moderators
  • 4985 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 27 March 2013 - 12:30 AM

You could try w3 total cache if you had problems with super cache -

Please Login or Register to see this Hidden Content







Also tagged with one or more of these keywords: speed, windows