Jump to content


Photo

my fonts being weird...

fonts

Best Answer jeffsbesthemp , 02 April 2013 - 05:00 AM

I wanted to follow up and let you know I found a solution, still don't know the cause, but the solution was that we needed to select a heading (1-5) to keep it level and ok. I noticed the page for my pandora station for our company didn't have the italics and when I looked at the code, it had solid heading tags formatted for the text. I went back and noticed that nothing on the about page had that, and when I tested it with formatting it as a h5 setting, viola, the italics disappeared. Thank God. Thank you for your help. 

Go to the full post


  • Please log in to reply
15 replies to this topic

#1 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 26 March 2013 - 04:15 AM

Hi,

 

for whatever reason, our fonts are posting really weird on the pages and blogs.

 

It will look normal when we're on the backend typing, but when it posts it's all in italics and different.

 

Can you help us figure out how to fix it?

 

here's an example http://jeffsbesthemp...rdpress/?p=1092

 

but when we look at it on the other side it looks nice normal Arial and bold type. 

 

We'd insert a screenshot but we can't see where to do that.

 

Thanks for any input you can offer.

 



#2 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 26 March 2013 - 04:59 AM

Hi there, I've been through your code and I can't see where that italic instruction is coming from, there's nothing there that seems to be making it do that.

 

Could you try disabling all third party plugins, to see if any of the styling inside them are causing the rest of the site to change.

 

If none of that works, try this css

 

 
html, body {font-style: normal !important;}


#3 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 26 March 2013 - 05:05 AM

ok cool. I'll give it a shot, both I mean. Thank you! :)



#4 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 26 March 2013 - 05:48 AM

Is there anything in my custom code that could throw it off? 

 

 

 

 body #primary-nav ul.sf-menu li a {font-weight: bold;font-size: 13px}
 
body div.branding_wrap {text-align: center;}
 
#branding .content-pad{padding-bottom:0px;}
 
#primary-nav ul.sf-menu ul li a{background:#80D23F}
 
div.media-frame {margin-top: -25px; ;}
 
.twitter {color:black !important;}
 
.comment {background:green !important;}
 
span.twitter a {color: #080408!important;}
 
.post-nav, .current_posts_info {
background: white;
}
 
.post-nav .previous a {
color: black;
}
 
.post-nav .next a {
color: black;
}
 
.post-footer {
color: black !important;
}
 
 
 
 
#site .mcolumn-pad {
background: white;
color: black;
}
 
#site .entry-title {
color: black;
}
 
#site .metabar .sword, #site em, #site .metabar a, #site .post-comments {
color: black;
}
html, body {font-style: normal !important;}


#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 26 March 2013 - 07:56 AM

The simplest way to find out if your custom CSS is the culprit, is to remove all your custom CSS and refresh your site.

If your text is still italicise, then its most likely you have added <em> to one of your posts/pages content via the editor and not added the </em>. So if removing your custom CSS, doesn't resolve the issue. You will need to start reviewing your posts/pages content.



#6 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 28 March 2013 - 05:58 AM

hi,

 

we deactivated all of our plugins, removed our custom css and looked at all our page info/post info click by click through the inspect element feature and still can't figure it out. They're all showing up weird with the italics. So frustrating. 



#7 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 28 March 2013 - 06:06 AM

The one thing we did notice is that all the Title parts are normal in the sense that:

 

Our main Menu is unaffected

The titles of our categories are unaffected

the titles of our posts are unaffected

 

What is a command or script that would affect all other text on the site, except that?

 

Where would we look to fix it?



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 March 2013 - 06:13 AM

he only way this kind of italic styling can happen without CSS, is if you have a missing </i>, </em> tag somewhere. You're going to need to review all your written content. This includes your widgets content, sections content such as features, boxes etc...

 

Update:

http://d.pr/i/NKU2

 

There is no </i>, this is the reason, so what that div is, you need to address the issue. In future, if you encounter this kind of issue again, I suggest you review your Page Source, before posting.



#9 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 28 March 2013 - 06:20 AM

whoa.... every page and post?

 

we're not programmers so is this something that needs to be done at that level? Like reviewing code used for each section in the editor you mean?

 

I wouldn't even know where to look or how to do that.



#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 March 2013 - 06:25 AM

When I mentioned all content, I wasn't referring to code, the issue isn't with the PageLines code but with the content that you have written. If you leave any kind of <strong>, <em>, <i> tag open, then this style with filter to all your below content. When using these tags you need to make sure that you close them.

 

However, I have find the cause of the issue I think, see my post above.



#11 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 28 March 2013 - 06:35 AM

that is so cool, you rock. Thank you we'll check it out!



#12 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 28 March 2013 - 06:40 AM

Hi,

 

Is that from our page with the "no fax payday loans" stuff? We're not sure why that's there.... 

 

We're stoked that you found the cause but it's still a little past us. 

 

Where do we go to fix this or what steps do we take to fix the part you pointed out?  



#13 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 March 2013 - 06:46 AM

Unfortunately, I have no idea, I don't even know what that <div> is used for, therefore, I am unable to assist you further. If this isn't something you have added yourself, then its most likely coming from a plugin.

 

Either way, this has to be removed as its certainly the cause of the issue, from what I can tell.

 

If you find that removing all plugins, doesn't resolve your issue, then you may have been hacked.



#14 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 28 March 2013 - 06:51 AM

ok we don't know either and hopefully it isn't hardwired into the platform theme. We'll find out and thank you for your help.



#15 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 March 2013 - 06:52 AM

No problem, happy to help.



#16 jeffsbesthemp

jeffsbesthemp

    Super Member

  • Members
  • PipPipPipPip
  • 133 posts
  • Framework Version:1.5.3
  • Country: Country Flag

Posted 02 April 2013 - 05:00 AM   Best Answer

I wanted to follow up and let you know I found a solution, still don't know the cause, but the solution was that we needed to select a heading (1-5) to keep it level and ok. I noticed the page for my pandora station for our company didn't have the italics and when I looked at the code, it had solid heading tags formatted for the text. I went back and noticed that nothing on the about page had that, and when I tested it with formatting it as a h5 setting, viola, the italics disappeared. Thank God. Thank you for your help. 







Also tagged with one or more of these keywords: fonts