Jump to content


Photo
- - - - -

Twinshot kills my nav selected page highlight


Best Answer Danny , 25 March 2013 - 08:17 AM

HI,

 

Your issue is related to the URL of your navigation menu item called "Work". When you click the URL, it goes to the following URL.

 

/work-2

This means that is there is already a page/post using this slug and has most likely been added to the trash but not permanently deleted, which you will need to do. Once this page using the work slug has been deleted permanently deleted. Edit your work page and remove the -2 and save the changes.

 

This should resolve your issue.

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 JesseMann

JesseMann

    Advanced Member

  • Members

  • 59 posts
  • Country: Country Flag

Posted 23 March 2013 - 11:33 PM

Without twinshot my nav works great and highlights the page im on. See image 1. But with twinshot that goes away. (image 2) Ive tried firebug but i dont know what class to look for. Any ideas?

 

 

Attached Files



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 March 2013 - 10:34 AM

Hi,

 

I have just this moment added TwinShot to my test site and my Nav Classic works as normal. Therefore, it is most likely related to a plugin or your custom code. I recommend disabling all non-PageLines plugins and see if this resolves the issue. If it doesn't remove all your custom code and see if this resolves the issue.



#3 JesseMann

JesseMann

    Advanced Member

  • Members

  • 59 posts
  • Country: Country Flag

Posted 24 March 2013 - 07:39 PM

Hey Ninja. Thanks for the help. I removed my custom code, and deactivated all non pl plugins and I have the same problem.

Please Login or Register to see this Hidden Content

.



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 24 March 2013 - 07:46 PM

Hi,

 

It's possible that there's a 3rd party plugin causing this conflict. It may create a conflict with both your CSS and CSS for Twinshot.

 

Try deactivating all your plugins other than the ones found in the PageLines Store.

 

Let us know how that goes.

 

a freylakhn Pesach!



#5 JesseMann

JesseMann

    Advanced Member

  • Members

  • 59 posts
  • Country: Country Flag

Posted 24 March 2013 - 08:39 PM

Thanks Egg! I deactivated all non pl plugins and deleted my custom code. I made the site live if you want to poke around. Thanks!

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 25 March 2013 - 08:17 AM   Best Answer

HI,

 

Your issue is related to the URL of your navigation menu item called "Work". When you click the URL, it goes to the following URL.

 

/work-2

This means that is there is already a page/post using this slug and has most likely been added to the trash but not permanently deleted, which you will need to do. Once this page using the work slug has been deleted permanently deleted. Edit your work page and remove the -2 and save the changes.

 

This should resolve your issue.


  • JesseMann likes this

#7 JesseMann

JesseMann

    Advanced Member

  • Members

  • 59 posts
  • Country: Country Flag

Posted 25 March 2013 - 03:31 PM

You are brilliant! Thank you!