Jump to content


Photo
- - - - -

Uncaught TypeError: Object [object Object] has no method 'sortable'


Best Answer alessandropascoli , 04 April 2013 - 12:34 PM

Ok, friends, would you like what the problem was? What sort of silly problem caused that error?

 

In wordpress/settings/reading the number of post to show was 999999: move down this number to 99 all it's fine...

If someone in the universe should have the same issue...

Go to the full post


  • Please log in to reply
28 replies to this topic

#1 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 21 March 2013 - 02:10 PM

In the admin, disabling ALL the plugin, i still have that error message on topic (see attachment).

Any suggestion?

 

Thanks

 

Website URL: 

Please Login or Register to see this Hidden Content


Framework Version: 2.4.1
WordPress Version: 3.5.1
Plugins in Use: none
Server/Host: Media Temple

 

 

 

Attached Files



#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 21 March 2013 - 03:26 PM

That kind of error is usually caused by a javascript conflict with a plugin.

 

You already said you have no plugins activated but in your screenshot you still have an SEO menu showing.

 

If you have tried with no plugins installed then try reuploading the framework, you can get the latest version from your members area.



#3 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 22 March 2013 - 11:41 AM

The screenshot was token before disabling all plugin.

By the way i did again and attach new screenshot of the whole page.

 

You can see what's going on and an error message as well:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 215744452 bytes) in/nfs/c08/h04/mnt/124366/domains/sezioneaurea.com/html/wp-content/themes/pagelines/admin/class.options.engine.php on line 900

 
 

 

PageLines-Admin_sezioneaureaWordPress.pn



#4 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 22 March 2013 - 11:53 AM

P.S. I reuploading the framework as well and still not working...



#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 22 March 2013 - 12:16 PM

Can you enable PageLines debug mode - PageLines > Site Options > Advanced. However, the way your settings are currently displayed, it will not far from the bottom.

 

Also, provide your PHPinfo, for information on how to do this, see this article - 

Please Login or Register to see this Hidden Content



#6 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 22 March 2013 - 02:01 PM

I can not enable PL debug mode because i can not click PageLines > Site Options > Advanced (is exactly the page that does not work).

 

 
PHP Version 5.3.15
You can checkit here: 

Please Login or Register to see this Hidden Content



#7 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 22 March 2013 - 08:57 PM

Are you on a multisite install?



#8 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 23 March 2013 - 06:42 AM

No.



#9 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 23 March 2013 - 07:34 AM

Could be a matter of PHP memory limit? I tried to change the php.ini file but without succes...

 

 

Looking at the original error message, it appears that WordPress is trying to use over 256MB of PHP memory. Unfortunately, this limit can not be supported on the (gs) Grid-Service. You will need to find out what is trying to request so much memory, and then see if you can have it require less memory to run.

 

Any idea? Thanks



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 23 March 2013 - 02:34 PM

Buongiorno!

 

It may be that your site, like millions of others, is under a DoS (Denial of Service) attack, which attempts to flood your site with commands to break it. Contact your hosting company and ask them to check to see if your site is being hit in bulk from a particular IP address or group of them.  Ask them how you can firewall these, and block them from attempted access to your server's control panel.

 

I believe what you're seeing is in fact, a symptom, not the actual problem. Liken it to having a cough when it's really the flu. I've had this same problem myself. If you are on a shared computer, try to upgrade to a VPS with cPanel. This will also reduce some of the server load.



#11 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 23 March 2013 - 05:02 PM

Buongiorno!

 

Checked with the Media Temple staff and no, we do not see any obvious signs of a DDoS in this website visitor statistics.

Must be something about PageLines framework: if we switch theme there are no problem at all...

 

It's getting a nightmare...



#12 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 March 2013 - 09:14 AM

Hi,

 

You never enabled PageLines debug mode, see above for information on how to enable it.



#13 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 24 March 2013 - 11:21 AM

Danny, i can not enable debug mode because i can not see the option checkbox. The page can not shown properly as can you see by the screen shot above. And not i never enabled it. I will. Now I am going to restore a previous whole backup with the previous PageLines version. Hope that works.

 

 

Downgraded PageLines to 2.4. ALL plugin disabled. Error still there (just below the "Blog and Posts" section):

PageLines > Site Options > "Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 215744452 bytes) in /nfs/c08/h04/mnt/124366/domains/sezioneaurea.com/html/wp-content/themes/pagelines/admin/class.options.engine.php on line 900"

 

...



#14 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 March 2013 - 12:08 PM

OK, I can guarantee, that PageLines Framework does not require more than 99MB of PHP memory, which according to your PHPinfo is what you have set. The PHP memory required for PageLines Framework is no more than 46MB. Therefore, if you have 99MB of memory allocated for PHP, then the most likely cause is a vast amount of plugins being installed.

 

If you have disabled all non-PageLines plugins and are still encountering this issue, then the issue is likely caused by your server configuration. If my memory serves me correctly, the Media Temple grid server, is basically another name for Share Hosting.

 

Shared hosting regardless of your host, is cheap hosting and I wouldn't recommend anyone to use Shared Hosting.

 

I am not an expert in terms of server configuration, so what I would recommend is contact Media Template, inform them of the situation that PageLines Framework will never use more than 46MB of memory allocated to PHP and ask them to investigate the issue.



#15 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 24 March 2013 - 12:14 PM

Thanks Danny,

we already investigated that yesterday with Media Temple and their answer was:

"This particular error may be caused by PHP memory limits being reached. If you are trying to allow for more memory for PHP functions, you can edit your "php.ini" file on the (gs) Grid-Service quite easily. It is located at "~/etc/php.ini"

"Looking at the original error message, it appears that WordPress is trying to use over 256MB of PHP memory. Unfortunately, this limit can not be supported on the (gs) Grid-Service. You will need to find out what is trying to request so much memory, and then see if you can have it require less memory to run.

Please do keep in mind that we are happy to help you set up everything regarding our servers, and will often go the extra mile to help you set up third-party software to access our servers correctly; however, we are not responsible for the configuration or malfunctions of third-party software."
 

But the point is this error occured suddenly few days ago without we did nothing at all, no upgrade, no upload, etc.

So if you assure me PL is not getting more than 46mb i am going to back with media temple support.



#16 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 March 2013 - 12:30 PM

Server configuration is by no means my forte but as far as I am aware Wordpress shouldn't be using over 256mb of memory, unless you have a very number of plugins installed. However, if this error only occurred a few days ago, with no changes at all done by yourself. Then in my opinion this is more evidence that there is an issue with your server configuration or your host has made some changes.



#17 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 26 March 2013 - 09:46 AM

Server insists: they did not change anything at all.

So, Danny, I see you are a member staff: is there any support service to buy to help us resolve this issue?



#18 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 26 March 2013 - 10:00 AM

Well usually the site options all being in one long list, is like Simon suggested above caused by a badly written plugin. Now you say you have disabled all plugins, so that isn't the cause of the issue. Also, the error regarding memory, I have never heard of seen a Wordpress installation require 256mb of memory.

So the only cause of the issue, has to be your servers configuration, this isn't something we can provide support for. However, as you have provided your PHPinfo, I will show this to one of our developers and see if he is can seen anything that could be causing the issue.

 

I will reply here when I have more information.



#19 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 26 March 2013 - 10:06 AM

Thanks.

At the moment php.ini is exactly this:

 

 
; Rename this file to php.ini and uncomment or add directives.
; For a complete list of valid directives, visit:
;  

Please Login or Register to see this Hidden Content

[PHP]
; We highly recommend that you leave this options enabled
cgi.fix_pathinfo=1
memory_limit = 99M
; Increase execution time
max_execution_time = 120
; Increase maximum post size
upload_max_filesize = 20M
post_max_size = 512M
; pull in EGPCS [Environment, GET, POST, Cookie, Server] variables as globals
;register_globals = true
; For performance reasons, (mt) does not load all of the modules that are available
; into PHP. You may uncomment any one of the following "extension" lines to enable
; the desired module
; Salblotron XSLT
;extension=xslt.so
; save in local tmp
session.save_path=/home/124366/data/tmp
allow_url_fopen = On
 
I enable back plugin that their are not causing the error. But if you need to investigate i can disable all of them.


#20 alessandropascoli

alessandropascoli

    Advanced Member

  • Members

  • 33 posts
  • Country: Country Flag

Posted 27 March 2013 - 11:17 AM

UPDATE

 

From the server hosting:

 

"You have a number of scripts installed on the domain sezioneauruea.com that are attempting to dynamically set the maximum memory limit as 256MB for PHP, rather than the actual maximum on the (gs) Grid-Service of 99MB. Performing an egrep for the string 256M returns the following list of files;

Please Login or Register to see this Hidden Content

Of these, the most prominent and likely culprits for this issue are;
./html/portfolio/wp-includes/default-constants.php
./html/portfolio/wp-admin/includes/file.php
./html/wp-admin/includes/file.php
./html/wp-includes/default-constants.php
Most of the other files defined either have simply a reference to 256M (usually commented out) or are relative to a plugin."
 
So I removed the entire "portofolio" directory and all the files/scripts they told me, except the wordpress core files:
./html/wp-admin/includes/file.php
./html/wp-includes/default-constants.php
 
Error still there. At this point must to be something in PageLines framework.
Can you help me? Is there anything else i can do?
 
P.S.
1. — Just instal the SAME website from the SAME backup on a different server. ALL plugin disabled. Just Pagelines framework on. Error still there...
2. — Removed Pagelines framework. ALL plugin disabled. downloaded and uploaded the brand new PL 2.4.1 from my account page. Activated (so JUST wordpress and Pagelines): Error still there...
 

Any suggestions?