Jump to content


Photo

columns off in mobile view only


  • Please log in to reply
9 replies to this topic

#1 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts
  • Country: Country Flag

Posted 12 March 2013 - 01:25 AM

Favor please? Can you look at this site in mobile view (www . ccbsi . com) and tell me if something looks off to you? In my android phone, the columns in subsequent horizontal sections are not lined up with the section above it as opposed to being page width? Please view in mobile and you'll see what I mean. How can I fix please? Do I need to ad a "clear" or something? What do I need to add and where (I need specifics, sorry). Again, looks ok in all browsers except in mobile. Confused. Thank you in advance for your time.



#2 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 12 March 2013 - 01:41 AM

Hi there

 

On my iphone it looks fine - http://screencast.com/t/X2uwN8BlqCm4

 

Have you tried clearing the cache on the phone to see if anything changes. Take a screenshot if possible so we can see what's happening.

 

Depending on how it is aligning, you might need to use some browser specific css to get it to align better, we have a plugin you can download - http://www.pagelines...ns/browser-css/

 

There's instructions on how to add the css here - http://support.pagel...r-specific-css/



#3 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts
  • Country: Country Flag

Posted 12 March 2013 - 02:01 AM

Thank you for the reply. I have an android (S3). Tried the clear cache and it did not work. Not sure how to attach a screenshot here. I'll try the plugin.



#4 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 12 March 2013 - 02:08 AM

A co-worker has just check in firefox and ie for android and says its coming up fine from what they can see. Which browser are you using on your phone?



#5 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts
  • Country: Country Flag

Posted 12 March 2013 - 02:28 AM

The internal IE browser (I have a Galaxy S3) sorry - having trouble finding where to add a screenshot :mellow:



#6 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 12 March 2013 - 02:55 AM

Hi there, you can upload your image to something like imgur () and then paste the link in here.



#7 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts
  • Country: Country Flag

Posted 12 March 2013 - 03:29 AM

Mmmm, you said you viewed on android phone in IE and it's showing ok? Can I just email you the screenshot of what I am seeing?


Edited by iems, 12 March 2013 - 03:32 AM.


#8 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 12 March 2013 - 03:41 AM

hmmm ok, that's strange as not appearing like that on a colleagues android phone. Check to see if there's an update for the browser maybe?

 

You could another layout option (your site is fixed at the moment by the looks of it) try switching to a responsive layout to see if this resolves the content section width or has any alternate effect.

 

Otherwise it's going to have to be a browser specific css solution, tweaking the code inside the mobile version of the site to make the #content section go full width.



#9 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts
  • Country: Country Flag

Posted 12 March 2013 - 03:55 AM

Browser specific css. Sounds like a hassle for a non-developer. I'll see what I can pull off.



#10 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 12 March 2013 - 04:27 AM

Ok, keep us posted