Jump to content


Photo
- - - - -

Wordpress conflicting with Pagelines excerpts...

continue reading excerpts read full article

Best Answer compartmentlife , 15 March 2013 - 08:04 PM

I discovered that the issue was the plugin, Q and A Plus... since I paid for this plugin I decided to modify the code rather than not using it. The function.php file uses the same excerpt code copied from the TwentyEleven Wordpress theme. I simply deleted all of it and it seems to be working. Sorry for the back and forth. It just doesn't seem to make sense sometimes trying to track down these conflicts.

Go to the full post


  • Please log in to reply
13 replies to this topic

#1 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 11 March 2013 - 02:37 PM

Wordpress: 3.5.1

Pagelines: 2.4

Base Theme: 1.0.2

Website:

Please Login or Register to see this Hidden Content

 

I cannot seem to figure out how to remove the "Continue reading" link from the bottom of post excerpts on the home page of one of my clients. I have configured the Pagelines Excerpts to 140 words, wanting a longer preview, but it is not recognizing this setting. How do I fix this?

 

ScreenShot2013-03-11at93050AM_zpsd9e9eca



#2 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 11 March 2013 - 02:59 PM

Hi Compartmentlife 

 

Did you manually add 'More' tag in the visual editor?  

Please Login or Register to see this Hidden Content



#3 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 11 March 2013 - 03:03 PM

Hi Compartmentlife 

 

Did you manually add 'More' tag in the visual editor?  

Please Login or Register to see this Hidden Content

 

No, the only thing in the visual editor is the image and text. My client wrote the blog post and doesn't even know how to add the "more" tag. It is happening on every post... I'm sorry, I didn't add the website link.

 

Here: 

Please Login or Register to see this Hidden Content



#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 11 March 2013 - 04:10 PM

It might  be easier to remove the "Read Full Article" link and then change the "Continue Reading" text to whatever you'd like (if you wanted different words).



#5 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 11 March 2013 - 04:15 PM

It might  be easier to remove the "Read Full Article" link and then change the "Continue Reading" text to whatever you'd like (if you wanted different words).

 

I didn't add the "Continue Reading" text... I have no idea how to edit or remove it and can't find any options in any menu to modify it. Plus, I want more text in the preview than it is allowing.



#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 11 March 2013 - 04:45 PM

Yes, but it might be easier to hide the read full text link and then adjust the Continue Reading text. First, try deactivating all active non-PL plugins to see if the problem with the number of excerpt words persists.



#7 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 13 March 2013 - 10:06 PM

This problem persists. I have not removed the Pagelines default "Read Full Article" and left the field blank, but it the displays [Continue Reading...] instead. I need a proper solution and want to be able to manager the excerpt length as designed.



#8 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 14 March 2013 - 03:38 AM

Hi there, ok go into the post that the client wrote and check in there to see if they added a manual excerpt inside the edit post field. If they did, remove it. screencast.com/t/1nzXIm77

 

Also check inside the post to see if the client added a more tag, this will display like this

Please Login or Register to see this Hidden Content

if they did, delete it.

 

Both of the above will affect the way the excerpt displays on the posts page.

 

Then go to Pagelines>site options>blogs and posts and scroll down and set the length for your excerpt, and the text you want for the continue reading button.

 

Please Login or Register to see this Hidden Content



#9 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 14 March 2013 - 03:50 AM

I have already been through this and it does not solve the problem. It is happening on every post, not just the one shown. Please look at the site.

I thought maybe Wordpress was causing this, so I removed excepts and all text disappeared. Then, I showed full text and the full posts appeared. Then a went back to excepts and it continues to show two "continue links" with no control over length...

#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 15702 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 14 March 2013 - 08:14 AM

HI,

 

On a fresh installation of Wordpress/PageLines both the latest version, I set the Excerpt length to 200 and clicked save, here is what I got.

 

Please Login or Register to see this Hidden Content

 

Therefore, I recommend you disable all non-PageLines plugins and sections and see if this resolves you issue, because with my fresh installation, there is no issue.



#11 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 15 March 2013 - 04:01 PM

Alright, now I'm having more problems. My custom CSS has stopped updating the site. The old code still works, but any new code is not being applied. I have deactivated ALL plugins, reinstalled the current version of Wordpress, cleared all browsing history and yet the home page still appears to be cached somehow. I continue to have more and more problems with pagelines on a regular basis and the site load speeds are terrible...



#12 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 15 March 2013 - 04:44 PM

Due to the caching issues, I DELETED WP Super Cache... It seems that even with it deactivated it was causing problems... My updates are now taking effect as they should and I removed the double [read more] posts. I will attempt reactivating each plugin one at a time to see if I find the conflict.



#13 compartmentlife

compartmentlife

    Advanced Member

  • Members
  • 98 posts
  • Country: Country Flag

Posted 15 March 2013 - 08:04 PM   Best Answer

I discovered that the issue was the plugin, Q and A Plus... since I paid for this plugin I decided to modify the code rather than not using it. The function.php file uses the same excerpt code copied from the TwentyEleven Wordpress theme. I simply deleted all of it and it seems to be working. Sorry for the back and forth. It just doesn't seem to make sense sometimes trying to track down these conflicts.



#14 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 16 March 2013 - 12:38 AM

We're glad you managed to get this sorted. Thank you for letting us know which plugin which was the cause, this will no help other users in the future.







Also tagged with one or more of these keywords: continue reading, excerpts, read full article