Jump to content


Photo
- - - - -

fix problem in IE on one page

ie page-id browswer-specific css

Best Answer Rob , 09 March 2013 - 05:25 PM

Peggy,

 

I think you must have an error in some coding related specifically to the form.  I'll explain my logic behind this:

1. The mis-sized code isn't really mis-sized, it's simply bolded, so likely you have an unclosed <strong> or <b> tag somewhere in the form or in custom html relating to the form.

2. The event only appears on this one page, following the form or after it, not preceding it, thus it must be something uniquely related to the form or widgets, not the page or PageLines, else it would appear elsewhere.

3. The CSS in IE9 and Firebug shows the same things.

 

Did you know IE9 has inspection tools similar to Firebug? Press F12 on your keyboard.

 

You can also review the HTML of the page using an HTML validator, which I did and found the error is coming from a text widget containing the times of your operation. See below.

Go to the full post


  • Please log in to reply
20 replies to this topic

#1 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 08 March 2013 - 03:16 PM

I have never been successful combining body.ie with .page-id-____ in css.  I can do it in firefox and chrome but not ie.  Is there some other way to do it with IE???

 

If you look at www.clearheartcoaching.com/contact-me in IE, everything below the contact form is HUGE. But only in that browser and only on that page

 


so ideally, to fix this, it wd be body.ie .page-id-113 .menu-footer-nav-container .pullquote ...

 

but nothing happens EVER with that browser combined with a page.

 

yes i have browser-specific plugin

 

Thanks for your help



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 08 March 2013 - 03:44 PM

You should try body.ie.page-id-113. page-id-113 is a class for the body tag, so it should be a part of the same selector.



#3 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 08 March 2013 - 04:07 PM

Thx! Do you mean that there shd be NO space between the the body and class tags? 

And that there should be spaces between that combined tag and the following footer and pullquote tags???

 

 

OK, I just re-tried it, and removing the space didnt work.  I think I'd tried that before...

 

Here's what I'm using, both with and without spaces, and even trying "!important":

 

body.ie.page-id-113 .menu-footer-nav-container .pullquote {

display: none;

}

 

What I'd really rather do is shrink the size of these elements as opposed to hiding them.

 

Please keep in mind, I've tried this combo of body.ie and page-id many times before with no success.  So I dont think its anything specific about this particular event



#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 08 March 2013 - 04:54 PM

Are you using the latest IE?



#5 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 08 March 2013 - 05:13 PM

version 9.08



#6 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 08 March 2013 - 09:42 PM

Hi there

 

These are the classes being shown on the page for the body, I can't see anything in there relating to IE. You can follow that format below though to insert a new instruction. Page id comes first.

 

 

Please Login or Register to see this Hidden Content



#7 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 08 March 2013 - 10:20 PM

james, I'm not so sure this is a css issue since nothing I do in css shows up on the page, and I do mean nothing. So, heres the deal. Everything on that page is huge, magnified, including the form. cd it be something else?



#8 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 08 March 2013 - 10:23 PM

I did as you suggested on Live and reversed the order of the page and bosy classes, which I'd also tried before but that made no difference. I do see that in that string at the top near the head, most every browser type I add in css is listed. but body.ie is not.  is there someplace to add that permanently?



#9 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 09 March 2013 - 02:44 AM

Hi Peggy,

 

The only other thing I can think to try is to put the pullquote on that page inside it's own div (give the div class a name) then use that followed by the pullquote in the css, instead of using the page-id.

 

Checked on the support docs and it says the body.ie class at the top of the page will only show in ie, if i look ony your site now i see firefox as that's the browser i'm using etc.

 

Please Login or Register to see this Hidden Content



#10 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 09 March 2013 - 02:17 PM

hey thx james.  I'll try this.  I'll try that with the footcols too.



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 March 2013 - 03:43 PM

Hi Peggy,

 

I just looked at the site and see no enlargement of anything out of the norm.  Below is a snapshot. Did you resolve the issue? 

 

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  76.58KB   2 downloads



#12 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 09 March 2013 - 04:46 PM

Rob, good morning!  Whatcha doin' workin on a Saturday morn?  No I have not resolved the issue.  Are you looking at it in IE?  Which is where the problem is?  IF so, which version of IE?



#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 March 2013 - 04:51 PM

Good morning Peggy,

 

Yes, it is IE, v. 9.0.8112.

 

It's possible changes aren't being seen in your browsers due to the browser cache.  Did you do a hard-refresh in IE? (Shift+F5)



#14 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 09 March 2013 - 05:06 PM

I pressed Shift + F5 on keyboard but nada. 2 diffferent keyboards: no response.  Rob, if it looks normal to you, meaning the same as on the other pages, then I'm just gonna fugettabouttit!   although, I wd lkike to see a screenshot.  Cdnt open the one you posted



#15 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 09 March 2013 - 05:08 PM

I take that back.  I just opened it.  The bottom items (nav and quote are huge compared to the other pages. hmmmmmmm. not a cache issue then.



#16 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 09 March 2013 - 05:14 PM

So back to James' idea?  But how do you asssign something to a class?  Dont see any doc...



#17 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 March 2013 - 05:25 PM   Best Answer

Peggy,

 

I think you must have an error in some coding related specifically to the form.  I'll explain my logic behind this:

1. The mis-sized code isn't really mis-sized, it's simply bolded, so likely you have an unclosed <strong> or <b> tag somewhere in the form or in custom html relating to the form.

2. The event only appears on this one page, following the form or after it, not preceding it, thus it must be something uniquely related to the form or widgets, not the page or PageLines, else it would appear elsewhere.

3. The CSS in IE9 and Firebug shows the same things.

 

Did you know IE9 has inspection tools similar to Firebug? Press F12 on your keyboard.

 

You can also review the HTML of the page using an HTML validator, which I did and found the error is coming from a text widget containing the times of your operation. See below.

Attached Files


  • pazyluz likes this

#18 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 March 2013 - 05:33 PM

James idea is a good one, of course, but since the text widget seems to have an unclosed <strong> tag, everything following it is picking up that and is appearing bold, even the pullquote.  If you removed that, I don't believe you'll see anything different, except the lack of your pullquote. 

 

Check the text widget used to apply the contact hours and I'm sure you'll find the issue. Validate it by direct input here:

Please Login or Register to see this Hidden Content



#19 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 09 March 2013 - 05:40 PM

Rob, is it my imagination, or is this Above sand Beyond?  Thanks.  I'll dig into that widget if I can remember how.



#20 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 March 2013 - 05:44 PM

Dashboard > Appearance > Widgets.  Select the sidebar it's using (probably Primary) and just drop down (open) the text widgets till you find that content. 

 

Copy the content, then validate it.  That will tell you if the code is correct.

 

Above, beyond, and probably over the top!

 

As always, glad to help.


  • pazyluz likes this





Also tagged with one or more of these keywords: ie, page-id, browswer-specific css