Jump to content


Photo

outgoing links add my website url

links

Best Answer pdean , 07 March 2013 - 11:09 AM

I went into the code and, strangely enough, the only link that worked was the one that had http:// included. So I added that to the others, and they all work now. So cutting and pasting the links won't necessarily work, I guess.

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 pdean

pdean

    Member

  • Members
  • PipPip
  • 29 posts

Posted 07 March 2013 - 01:24 AM

When I create a link in Edit Page mode, the link looks fine in the 'insert/edit link' popup box, but when published, my website url and /links/ is added. So instead of website.org, the link opens with mywebsite.com/links/website.org.

 

Thanks for any help.



#2 James B

James B

    Advocate

  • Moderators
  • 4978 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 07 March 2013 - 01:46 AM

Hi there,

 

Is you disable your third party plugins does this stop happening? The only item I can find which has the same problem is down to a plugin rewriting the link, check out - http://wordpress.org...-address-before



#3 pdean

pdean

    Member

  • Members
  • PipPip
  • 29 posts

Posted 07 March 2013 - 11:09 AM   Best Answer

I went into the code and, strangely enough, the only link that worked was the one that had http:// included. So I added that to the others, and they all work now. So cutting and pasting the links won't necessarily work, I guess.



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 12929 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 07 March 2013 - 11:38 AM

When adding links be sure to always add the http:// to the URL, If you don't it will be classed as an internal URL.







Also tagged with one or more of these keywords: links