Jump to content


Photo
* * * * * 1 votes

Feature Links Opening in New Window

Features Customize

Best Answer daveschroeder , 08 March 2013 - 05:52 PM

Just got back... It turns out that GoDaddy.com says they don't install Posix for "security reasons" and that if I want it from them I'll have to get a dedicated server.

Next year, I'll move to another hosting provider! Go to the full post


This topic has been archived. This means that you cannot reply to this topic.
27 replies to this topic

#21 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 08 March 2013 - 11:23 AM



#22 daveschroeder

daveschroeder

    Member

  • Members
  • 16 posts

Posted 08 March 2013 - 12:34 PM

Hi Simon --

 

I copied the line above into the end of the pagelines-customize functions.php file for a test site,

Please Login or Register to see this Hidden Content

I set the links for the default PageLines Features slides to google.com.

 

I'm not getting any error messages, though.

 

You can check it out -- they're still opening "_self" instead of opening new windows.

 

Sorry for the hassle -- thanks -- Dave



#23 Danny

Danny

    Is Awesome!

  • Moderators
  • 18845 posts

Posted 08 March 2013 - 12:45 PM

Hi Dave,

 

No need to apologise, can you do us a favour and enable PageLines debug mode please and also take a screenshot of your PageLines Customize plugins functions.php please, so we can see the code.

 

Enable PageLines debug: PageLines > Site Options > Advanced.



#24 daveschroeder

daveschroeder

    Member

  • Members
  • 16 posts

Posted 08 March 2013 - 01:06 PM

Hi Danny --

 

No worries!  I have to leave to visit a client now -- the one who needs this functionality -- but can check the status via email. 

 

Much obliged -- Dave

 

functionsDOTphp%20screen%20shot.jpg



#25 Danny

Danny

    Is Awesome!

  • Moderators
  • 18845 posts

Posted 08 March 2013 - 01:13 PM

Hi Dave,

 

The code in your customisation plugin functions.php file looks fine as far as I can see. However, you didn't enable PageLines debug mode.



#26 daveschroeder

daveschroeder

    Member

  • Members
  • 16 posts

Posted 08 March 2013 - 01:16 PM

I must not have hit Save. 

 

I have to get on the road now, but please see if that does it.

 

Much obliged -- Dave



#27 Danny

Danny

    Is Awesome!

  • Moderators
  • 18845 posts

Posted 08 March 2013 - 01:28 PM

Thanks that did the trick.


When viewing your debug information you have the following, which may be causing the issue.

 

PHP User : Posix functions are disabled on this host!

PHP Magic Quotes gpc : Yes (bad)

I recommend you contact your host and ask them to resolve this.

Posix by default is enabled in PHP, your host has disabled it for some reason.



#28 daveschroeder

daveschroeder

    Member

  • Members
  • 16 posts

Posted 08 March 2013 - 05:52 PM   Best Answer

Just got back... It turns out that GoDaddy.com says they don't install Posix for "security reasons" and that if I want it from them I'll have to get a dedicated server.

Next year, I'll move to another hosting provider!