Jump to content


Photo
- - - - -

Thumbnails not displayed with excerpts!

Blog post settings

Best Answer Rob , 05 March 2013 - 12:35 AM

Okay, here's the problem.

 

Your posts do not have a featured image set.  You have included an image in the body of the post, but not set the image as the featured image.

 

You can see the set featured image here: http://racineinternetmarketing.com/ in the first post. When you go to it: http://racineinterne...ssential-steps/ you can see both the image you added to the body of the post and the one I added as the featured image.

 

The reason you didn't see them in the blog page is simple.  You were displaying excerpts. The excerpt doesn't pick up images.  It's for words, not graphics, picking up the first XX words (default is 55) from the post.  It instinctively ignores HTML code to prevent coding conflicts.  So, use the Featured Image option (a WordPress function, not PageLines). 

 

You saw them on full length posts because the image is in the full content.  See the bit on Setting a Post Thumbnail here: http://codex.wordpre...Post_Thumbnails

 

Please remove the admin level account when you have a moment.

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 robin2321

robin2321

    Member

  • Members
  • 17 posts
  • LocationRacine WI
  • Framework Version:Developer
  • Country: Country Flag

Posted 04 March 2013 - 06:11 PM

I can't get thumbnail images to display alongside the excerpts on the blog post page. The thumbnails are visable on the post page okay but not on the blog page. The thumbnails are 150 x 150 and I shrunk that down to 50% and still no images. I have tried all of the various settings in the blog post meta-and nothing seems to work also, I made sure there was no duplicate content with the meta configuration settings.
What am I missing?



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 04 March 2013 - 07:15 PM

Did you check to make sure that thumbnails are set to appear on Posts Page in PageLines > Site Options > Blog and Posts?



#3 robin2321

robin2321

    Member

  • Members
  • 17 posts
  • LocationRacine WI
  • Framework Version:Developer
  • Country: Country Flag

Posted 04 March 2013 - 09:45 PM

Yes  - Here are my  Site Options setting    Site Theme is Ignite

 

Blog post layout

  • magazine layout mode

 

Feature post excerpt mode

  • left in excerpts

 

Post thumbnail Placement

  • Post/Blog Page
  • Single Posts
  • Inpost Clips (Magazine Mode)

 

Post Excerpt Summary Handling

  • Post/Blog Page

 

Full Post Comtent

  • Search Results
  • Category Lists
  • Post Archives


#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 March 2013 - 10:32 PM

Hi, everything looks correct, with one possible exception.

 

I'd recommend leaving all the options in Full Post Content unchecked.  There may simply be a conflict if WP is considering some posts to be archived.



#5 robin2321

robin2321

    Member

  • Members
  • 17 posts
  • LocationRacine WI
  • Framework Version:Developer
  • Country: Country Flag

Posted 04 March 2013 - 11:42 PM

Uncheck all the Full Post content and no change  What do suggest I try next?



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 March 2013 - 11:46 PM

Robin, if you'd like, create a new administrator level user and send me the credentials.  Use robert@pagelines.com.  I'll take a look to see if there's anything I can find.



#7 robin2321

robin2321

    Member

  • Members
  • 17 posts
  • LocationRacine WI
  • Framework Version:Developer
  • Country: Country Flag

Posted 04 March 2013 - 11:56 PM

just sent you an email with login info



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 March 2013 - 11:58 PM

Thanks.  It doesn't appear to be an Administrator level login though.



#9 robin2321

robin2321

    Member

  • Members
  • 17 posts
  • LocationRacine WI
  • Framework Version:Developer
  • Country: Country Flag

Posted 05 March 2013 - 12:18 AM

is now!  sorry about that



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 05 March 2013 - 12:35 AM   Best Answer

Okay, here's the problem.

 

Your posts do not have a featured image set.  You have included an image in the body of the post, but not set the image as the featured image.

 

You can see the set featured image here:

Please Login or Register to see this Hidden Content

in the first post. When you go to it:

Please Login or Register to see this Hidden Content

you can see both the image you added to the body of the post and the one I added as the featured image.

 

The reason you didn't see them in the blog page is simple.  You were displaying excerpts. The excerpt doesn't pick up images.  It's for words, not graphics, picking up the first XX words (default is 55) from the post.  It instinctively ignores HTML code to prevent coding conflicts.  So, use the Featured Image option (a WordPress function, not PageLines). 

 

You saw them on full length posts because the image is in the full content.  See the bit on Setting a Post Thumbnail here:

Please Login or Register to see this Hidden Content

 

Please remove the admin level account when you have a moment.



#11 robin2321

robin2321

    Member

  • Members
  • 17 posts
  • LocationRacine WI
  • Framework Version:Developer
  • Country: Country Flag

Posted 05 March 2013 - 01:02 AM

THANKS FOR YOUR HELP!

I really appreciate it - I now understand what was happening, I spent hours today trying to solve this problem. Again Thanks



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 05 March 2013 - 01:04 AM

No problem. Always a pleasure.