Jump to content


Photo

need help -- "warning: creating default object from empty value in ..."


  • Please log in to reply
3 replies to this topic

#1 nicole_stottlemyer

nicole_stottlemyer

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country: Country Flag

Posted 28 February 2013 - 03:49 AM

i was in wordpress, and i went to change my theme to pagelines. i clicked activate, and this came up. now, i can't get it to go away. 

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 164

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 167

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 170

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 173

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 176

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 178

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 180

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 202

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 206

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 224

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 225

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 227

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/admin/class.options.metapanel.php on line 49

Warning: Cannot modify header information - headers already sent by (output started at /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php:164) in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-login.php on line 368

Warning: Cannot modify header information - headers already sent by (output started at /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php:164) in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-login.php on line 380

Warning: Cannot modify header information - headers already sent by (output started at /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php:164) in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-includes/pluggable.php on line 680

Warning: Cannot modify header information - headers already sent by (output started at /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php:164) in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-includes/pluggable.php on line 681

Warning: Cannot modify header information - headers already sent by (output started at /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php:164) in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-includes/pluggable.php on line 682

Warning: Cannot modify header information - headers already sent by (output started at /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-content/themes/platform/includes/class.layout.php:164) in /homepages/6/d456065728/htdocs/nicoletalks.com wordpress/wp-includes/pluggable.php on line 876



#2 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 28 February 2013 - 05:32 AM

Hi there, these warnings are showing as debug seems to be on and you could have some unwanted spaces in the wp-config file - http://www.hongkiat....er-information/

 

You'll need to set the below in the wp-config.php to turn off the warnings.

define('WP_DEBUG', false);

For full information on turning off debug please see the following link - http://codex.wordpress.org/WP_DEBUG your host might be able to do this for you.



#3 depepi

depepi

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 30 June 2013 - 08:27 PM

I have the same issue.

I added define('WP_DEBUG', false); in the wp-config.php and I still get the warnings. 

Also no unwanted spaces in the wp-config.php it's the same coming from the latest version from wordpress.org

 

I have a display_startup_errors = Off in my production php.ini but the error logs from apache are full of this messages, making logs huge because for every single view I have all that dumped into the error logs file.

 

Is there a way to fix this? Actually it doesn't have a visible impact in the site but it has an internal impact. 

 

Thanks.



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 30 June 2013 - 10:33 PM

Hi depepi,

 

PlatformPro has reached the end of its life cycle. I do not know the impact this has on the free versions.

 

If you are getting messages in error logs in Apache, then the settings controlling those are server settings, not from Platform.

 

If you want to install PageLines Framework, which is recommended, strongly, then follow the instructions at http://support.pagelines.me/docs

 

But you should talk to your hosting company about the settings causing those error logs.