Jump to content


Photo
Events

Setting Up A Single Event In Content Section



Best Answer beardedavenger , 27 February 2013 - 11:54 PM

OK works now.

 

You didn't have the loop section in the page template. ;)

 

Nick

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 James Giroux

James Giroux

    Community Director

  • Moderators

  • 161 posts
  • LocationOttawa, Canada
  • Framework Version:Developer
  • Country: Country Flag

Posted 27 February 2013 - 08:34 PM

Hey Nick.
 
I LOVE the work you are doing for pagelines extending, it's great.  So, I've got a clean install of pagelines, I activated the events section, followed the instructions for setting it up and for some reason I'm having trouble getting single events to display.  What I'd like to do is feature a single event on my home page that a user can click on for more information.  Here's what I'm entering for code:

 

[event_single id="23"]

 

So, the ID there is what I see when I want to edit the event but when I click on the view link, I actually get the slug for the event title.  I'm trying to troubleshoot this and I'm not sure what I'm doing wrong.

 

I've imported the sample data to try and figure it out but I don't think there's a single event example in there.  Also, I'm noticing that agenda content isn't showing up on any event either.

 

Any ideas on what I'm doing wrong?

 

Cheers.

 

James. 



#2 James Giroux

James Giroux

    Community Director

  • Moderators

  • 161 posts
  • LocationOttawa, Canada
  • Framework Version:Developer
  • Country: Country Flag

Posted 27 February 2013 - 08:37 PM

Hey,

 

The link for the setup is at http://ecd.transform...unications.com.

 

James.



#3 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 27 February 2013 - 08:49 PM

Right on, so when you go to edit the even in wp-admin, check out the browser bar and that number is the id of the event.

 

http://screencast.com/t/dzzGYb6lr

 

Nick



#4 James Giroux

James Giroux

    Community Director

  • Moderators

  • 161 posts
  • LocationOttawa, Canada
  • Framework Version:Developer
  • Country: Country Flag

Posted 27 February 2013 - 08:50 PM

That's where I'm getting "23" from.  For some reason though, the shortcode doesn't seem to work when setting it up on my home page.  Am I able to use that shortcode outside of an event post?  



#5 James Giroux

James Giroux

    Community Director

  • Moderators

  • 161 posts
  • LocationOttawa, Canada
  • Framework Version:Developer
  • Country: Country Flag

Posted 27 February 2013 - 08:54 PM

Here's all I have in the content box for my home page.

 

http://www.screencast.com/t/QrMSfRn4LG



#6 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 27 February 2013 - 11:35 PM

Do you have the section activated? When I go to the events archive there's nothing there

http://ecd.transform...ons.com/events/



#7 James Giroux

James Giroux

    Community Director

  • Moderators

  • 161 posts
  • LocationOttawa, Canada
  • Framework Version:Developer
  • Country: Country Flag

Posted 27 February 2013 - 11:42 PM

Hey Nick,

 

Sorry to cause so much stress.  Yes, the section is activated.  I'm using the slugs event and events.  Individual events are accessible but for some reason the archives aren't.

 

http://www.screencast.com/t/4knQpK2nD

 

Here's a link to an event: 

 

http://ecd.transform...rict-conference



#8 James Giroux

James Giroux

    Community Director

  • Moderators

  • 161 posts
  • LocationOttawa, Canada
  • Framework Version:Developer
  • Country: Country Flag

Posted 27 February 2013 - 11:43 PM

Here's a link to one of your events, notice that the agenda doesn't show up in the bottom.

 

http://ecd.transform...nts=scary-right



#9 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 27 February 2013 - 11:54 PM   Best Answer

OK works now.

 

You didn't have the loop section in the page template. ;)

 

Nick



#10 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 27 February 2013 - 11:55 PM

You also should set your permalinks so the event archives show. Choose Monday and Day or something other than default.



#11 James Giroux

James Giroux

    Community Director

  • Moderators

  • 161 posts
  • LocationOttawa, Canada
  • Framework Version:Developer
  • Country: Country Flag

Posted 27 February 2013 - 11:58 PM

Hey Nick,

 

I usually tweak the permalinks but was hoping on a fresh install to get things working first.  Thanks for the help.  I didn't think I needed the post loop in the home page if I wasn't wanting it there.  But I guess now I know better.

 

Thanks,

 

James.



#12 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 28 February 2013 - 12:03 AM

Ya if you have anything in that edit window, it will be in the loop just so ya know.







Also tagged with one or more of these keywords: Events