Archived

This topic is now archived and is closed to further replies.

Browser Specific CSS - more browser versions please


4 posts in this topic

Posted · Report post

Is it possible that your Browser Specific CSS plugin could be updated to include classes for the versions for the most popular browsers?

 

ie is the only browser that has classes for its versions (.ie9 .ie8 and so on...) at present and it would be very useful if there were versions for firefox, chrome, safari and opera. For example I'm finding differences between opera 12.12 and 11.6, all looks good in latest version but the next youngest there are a couple of issues so I can't apply any CSS to .opera as the latest version is fine.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi MissT,

 

I've not heard of this before outside of ie, but we'll pass this suggestion on to the core team for you :-)

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks James, there is a non Pagelines plugin that does something similar - 'Awebsome! Browser Selector' - it seems to work in a similar way but it has a separate class for the version e.g. .opera .v11. 

 

Thanks again :)

Share this post


Link to post
Share on other sites

Posted · Report post

You're welcome, a client also sent in a modified version of the browser specific plugin which some additional classes, I've sent these both through for review :-)

Share this post


Link to post
Share on other sites