Jump to content


Photo
- - - - -

Can't edit text after changing domain name

change domain cannot edit tex

Best Answer himalaya01 , 27 February 2013 - 08:03 AM

Found out wich plugin it is. It is Wordpress Page Widgets.

Before I didn't have any problems with the plugin.

I think reinstalling is the best option?

 

Thanx

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 himalaya01

himalaya01

    Advanced Member

  • Members
  • 57 posts
  • Framework Version:2.3.7
  • Country: Country Flag

Posted 26 February 2013 - 09:25 PM

Hi,

 

I have changed my domain name and for some reason I can see text on my website but I can't edit text, the editor is blank and I cannot type in the editor. I can see how many word I have used at the bottom of the text editor.

 

This is are the things I have done:

- I bought a new domain

- Changed the primary domain in the settings of my webhost, automatically the new domain was matched to the changed primary domain

- Uploaded al the pictures from the new path they are in.

- have put these two lines in wp-config; source:

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

-Couldn't log in, added these two lines to functions.php and removed them within a couple of minutes; source:

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

- changes Path to backup in wp-db Manager options

 

- acidentally deleted the "rewrite engine" code in my .htaccess file , after that Wp Super Cache gave a message that I should put a suggested "rewrite engine" code in .htaccess file, I copied the code and pasted the code into it.

 

How can I fix this?

 

thanx

 



#2 James B

James B

    Advocate

  • Moderators
  • 4985 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 26 February 2013 - 10:25 PM

I'd say disable super cache whilst you're trying to get this fixed.

 

 

Couple of things to check with you. If you switch to html/text view in the wp editior can you see the text in there?

 

Did you do a find and replace in the urls when you transferred the database? Or are you just using the code above to override this?

 

If you disable all third party plugins and fully clear the browser cache does the text reappear?

 

Did you upgrade wordpress or pagelines on the new install when you transferred?



#3 himalaya01

himalaya01

    Advanced Member

  • Members
  • 57 posts
  • Framework Version:2.3.7
  • Country: Country Flag

Posted 27 February 2013 - 07:32 AM

Hi James,

 

I Disabled Super Cache, but didn't remove it. > didn't work.

 

When I am in html editor I can't see text, I can't even type but I see a menu. When I switch to visual-text editor, there is no menu and I can't type as well.

In both the editors I can see the number of words.

 

I don,t know how to do a find and replace in the urls, actually I didn't transfer the database.  When I bought a new domain with my host, they said I had to change the primary domain name of the database to the name of the new domain. the  new domain I bought and the database connected automatically.  I only used the code described above.

 

I did not upgrade wordpress Or Pagelines.

 

I disabled all plugins and the text is visible again. I did not change anything , I had the same plugins on the old domain.

Does it mean I can't use a plugin anymore? What can I do to fix this?

 

Thanx



#4 himalaya01

himalaya01

    Advanced Member

  • Members
  • 57 posts
  • Framework Version:2.3.7
  • Country: Country Flag

Posted 27 February 2013 - 08:03 AM   Best Answer

Found out wich plugin it is. It is Wordpress Page Widgets.

Before I didn't have any problems with the plugin.

I think reinstalling is the best option?

 

Thanx



#5 himalaya01

himalaya01

    Advanced Member

  • Members
  • 57 posts
  • Framework Version:2.3.7
  • Country: Country Flag

Posted 27 February 2013 - 09:00 AM

Fixed the problem :)

After reinstalling WP Page Widgets the text is visible again.

 

Thanx for the advice!