Jump to content


Photo
- - - - -

Slow page load times


Best Answer elangley , 15 April 2013 - 12:12 AM

Moving to CentOS improved performance dramatically...

Go to the full post


  • Please log in to reply
22 replies to this topic

#1 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 26 February 2013 - 08:30 PM

Hello All,

 

Running Pagelines for the first time on a network of WordPress Multisite sites.

 

Page load times are pretty bad on sites that don't even have images on them. 

 

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

 

Competitive products are saying that Pagelines is inherently slow. 

 

Is there a fix for this?

 

~eric

 



#2 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 26 February 2013 - 11:40 PM

Hi Elangely

 

Take a look at this post which was created by one of our developers, there's some suggested resources and tips on there which could help.

 

Please Login or Register to see this Hidden Content



#3 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 01:19 PM

James,

 

I took a look at this post. This site is hosted on dedicated Amazon EC2 server with plenty of ram overhead and processing capability. No other sites are hosted on it. SuHosin is disabled.

 

We setup W3 Total Cache and a CDN. However, my colleague notes the following;

the theme is storing options and then outputting those options as css it will also cause the page to load slower than a theme that has styles properly styled in a css file. This is also causing the CDN to not cache images generated by the theme. 

 

Your thoughts? 

 

~eric



#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 March 2013 - 01:48 PM

Is the CSS being written to a file or loaded dynamically?

#5 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 02:27 PM

Loaded dynamically probably.

 

I tried to use this from another post; Enable the static css file mode by adding define( 'LESS_FILE_MODE', true ); to wp-config.php 

 

But when I enable it the site breaks. 

 

~eric



#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 March 2013 - 04:25 PM

You dont ned that define line that was pre 2.4.

 

If your server is capable of writing a file and the server is setup right it will right the css file, if not it defaults to loading it dynamically.

 

As with all threads asking about speed all we ask is that you go to advanced tab and enable debug so we can see if there is anything to help.

 

Most likely you are running apache with mod_php so the php process is nobody or www-data.



#7 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 04:35 PM

Okay, so the less_file_mode is no longer required. My colleague reports that the site is loading the css dynamically. 

 

It's hudsongrille.com what do I need to do to have it be written?

 

He states; ' the theme is storing options and then outputting those options as css it will also cause the page to load slower than a theme that has styles properly styled in a css file. 

 
This is also causing the CDN to not cache images generated by the theme. 
 
~eric


#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 March 2013 - 04:36 PM

Yes, I read that in the reply you posted above, no need to repeat.

 

As with all threads asking about speed all we ask is that you go to advanced tab and enable debug so we can see if there is anything to help.



#9 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 04:43 PM

Simon, 

 

Okay I enabled debug, under Site Options/Advanced.

 

What next?

 

~eric



#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 March 2013 - 04:45 PM

Well we cant do anything at all until you turn off all the disk thrashing caching.



#11 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 04:50 PM

Done

 

Just as a comparison the old site loads in less than 2 seconds, often less than 1, metrocafes.com



#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 March 2013 - 04:52 PM

Still just seeing cached pages.



#13 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 04:59 PM

I disabled the W3 Total Cache plugin. Try now. 



#14 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 March 2013 - 05:00 PM

Still just cached pages. Please re-enable then purge the cache then disable it.



#15 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 05:07 PM

Here what I did;

I enabled the plugin, there was no option to purge cache, I enabled page and object caching, clicked the purge cache button, disabled all, deactivated the plugin.\

 

I also removed a third party widget from the home screen.

 

The page size is now 429.7kb and takes longer than 5 seconds to load



#16 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 March 2013 - 05:59 PM

Sorry, but am still showing cached pages for both sites listed in your opening post.

 

This is exactly why we discourage caching plugins until your completely finished designing a site.

 

You need to empty the cache folder, wherever that is.



#17 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 01 March 2013 - 09:11 PM

By both sites, you mean 1) metrocafes.com (which is the old site and may be cached but we are not doing anything with it, it was just for a speed comparison) and 2) hudsongrille.com, the cache plugin is disabled for that site. I don't see anyplace where there is a cache folder though...

 

As for discouraging caching plugins until you are completely finished designing a site, why do you assume that we are not finished? When is a website finished that has dynamic content?



#18 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 02 March 2013 - 01:13 AM

Sorry, I guess we should start this thread again.

I was checking the two urls you posted in your opening post. Now you have provided two more urls.

So i looked at one, yes you have debug on.

PHP type : Apache2handler

PHP User : Posix functions are disabled on this host!

OS : WINNT

 

There is a slim possibility the filemode can be forced to ignore all 3 of these problems with the following filter, but there is absolutely no guarantee as you are using windows.

 



#19 elangley

elangley

    Member

  • Members
  • 27 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 02 March 2013 - 01:19 AM

The just shows you how difficult communication is, especially in a threaded post. 

 

So the site that we are testing is hudsongrille.com 

 

One thing, even though I am technologist sometimes step by step instruction is best.

 

Where would this "add_filter" go?

 

~eric



#20 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 02 March 2013 - 01:21 AM

To be fair you didn't mention that URL in the topic. Add the filter to either a child theme functions.php or the free customise plugin functions.php Sent from my iPad using Tapatalk HD