Jump to content


Photo

Error: Warning: Creating default object from empty value


  • Please log in to reply
5 replies to this topic

#1 amir

amir

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 23 February 2013 - 08:32 PM

Hi,

Recently I receive an error visiting my website. I have not install any new plugins or anything else. Everything was working well since I have been using PageLine PlatformPro, but for some reason I am getting the following error message. Please let me know what I can do to fix this problem.

 

My website address is:

www.campion1962.com

 

I really appreciate your help.

 

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 164

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 167

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 170

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 173

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 176

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 178

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 180

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 202

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 206

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 224

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 225

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 227

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/includes/class.layout.php on line 321

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 56

Warning: Creating default object from empty value in /public_html/wp-content/themes/platformpro/admin/class.options.metapanel.php on line 49



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 February 2013 - 09:31 AM

Hi Amir,

 

Have you made any changes to the core files at all ?

 

Also, you're currently using version 1.5.3, the latest version is 1.6.0, therefore I recommend updating the newer version and see if this resolves your issue. You will most likely need to update via FTP.

 

You can probably try this.

 

  1. Download a fresh copy of Platform Pro from your PageLines Launchpad.
  2. Connect to your site via FTP and navigate to /wp-content/themes/
  3. Now rename the platformpro folder to something like this: old_platformpro

 

  • Once you have done the above, unzip the newly downloaded copy of PlatformPro and upload the platformpro folder to /wp-content/themes/
  • Your themes folder should look something like this:
  • Twenty Ten
  • Twenty Eleven
  • Twenty Twelve
  • old_platformpro
  • platformpro

Now once the above has been completed, refresh your website and hopefully this has resolved your issue.



#3 amir

amir

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 25 February 2013 - 03:24 AM

Hi Danny,

No, I have not changed anything in the core. The only thing happened to my server was that they updated the PHP to 5.4.1 version few weeks ago.

I updated the Platformpro to the newest version as you recommended, but the error message is still coming up. I hope you can give me another suggestions. I really appreciate it.



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 25 February 2013 - 09:29 AM

See this topic, it may resolve your issue.

 

http://www.pagelines...corelibrarycla/



#5 amir

amir

    Advanced Member

  • Members
  • 30 posts
  • Country: Country Flag

Posted 25 February 2013 - 02:43 PM

Hi Danny,

I turned off the error message reporting through php.ini and it worked out. Thank you for your suggestion. But, I am just thinking, why should these errors be produced in the first place? Anyway, I am very thankful for your help.

 

Amir



#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 25 February 2013 - 04:25 PM

PlatformPro has not been updated to not show those warnings in php5.4, php5.3 wasnt even out then lol.

 

They are just warnings, nothing major.