Jump to content


Photo
- - - - -

Featured Media Image and Background Full Width

featured media background advanced

  • Please log in to reply
1 reply to this topic

#1 fatchamp

fatchamp

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 23 February 2013 - 07:57 AM

Hello, I've set the Featured section to fetch all latest posts in Site Defaults under Page Options.

And because my aim is to have the image on the left and content on the right, I've also turned on the Advanced mode for the Feature Setup Option to be visible in every post. That's where I individually set the respective post image as Media instead of Full Background to achieve the layout I want.

 

The result is that the Media image indeed appear on the left and content on the right, but the same image appeared as full-width background image as well.

 

Attached is a screenshot for you to view.

 

Maybe when I set a sitewide default, it is on autopilot to draw all photos to set as background already.

Not sure if anything can be done within the options.

Right now, one option I have is to individually create the features by duplicating all contents from the blog posts to the featured section, which is double work.

The other is probably to add a colored background to replace the full-width background.

Maybe you can help with a better solution, thanks!

 

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  48.54KB   16 downloads



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17931 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 February 2013 - 10:15 AM

Hi,

 

I have just tested this and I uploaded a image to a post for the featured image, which is most likely what all your posts will have and I also used the following options, in the advanced features posts meta options:

 

Please Login or Register to see this Hidden Content

 

The Result is I have two images, as both the Feature image (full width) and the Media Area - Image (optional) are loaded. As you can see from my image below, I only want to have the Media Area - Image (optional) image loaded.

 

Please Login or Register to see this Hidden Content

 

Therefore, I think this may be a minor bug, which I have reported. What you can do in the mean time, is apply custom CSS to the feature text area, and give it a strong colored background, such as black which will hide the full width featured image.

 

Like so - 

Please Login or Register to see this Hidden Content







Also tagged with one or more of these keywords: featured, media, background, advanced