Jump to content


Photo
- - - - -

Warning: Unable to allocate memory for pool . Solution please.


  • Please log in to reply
10 replies to this topic

#1 trisquelmedia

trisquelmedia

    Super Member

  • Members
  • 151 posts

Posted 21 February 2013 - 11:30 AM

[21-Feb-2013 10:37:09] PHP Warning:  include() [<a href='function.include'>function.include</a>]: Unable to allocate memory for pool. in /usr/home/misitio.es/web/wp-content/themes/pagelines/includes/class.register.php on line 141
[21-Feb-2013 10:37:09] PHP Warning:  include() [<a href='function.include'>function.include</a>]: Unable to allocate memory for pool. in /usr/home/misitio.es/web/wp-content/themes/pagelines/includes/class.register.php on line 141
[21-Feb-2013 10:37:09] PHP Warning:  require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in /usr/home/misitio.es/web/wp-content/themes/pagelines/includes/init.php on line 247
[21-Feb-2013 10:37:09] PHP Warning:  require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in /usr/home/misitio.es/web/wp-content/themes/pagelines/includes/init.php on line 249
[21-Feb-2013 10:37:09] PHP Warning:  require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in /usr/home/misitio.es/web/wp-content/themes/pagelines/includes/init.php on line 254
[21-Feb-2013 10:37:09] PHP Warning:  require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in /usr/home/misitio.es/web/wp-content/themes/pagelines/includes/init.php on line 254
[21-Feb-2013 10:37:09] PHP Warning:  require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to allocate memory for pool. in /usr/home/misitio.es/web/wp-content/themes/pagelines/includes/init.php on line 270
 

 

The error happens occasionally.

 

Hosting support tell me that this error is caused by the APC PHP accelerator, but I dont use any such plugin (W3 Cache, etc etc)

 

 

I dont use many plugins, server PHP Memory is 128 MB, how i solve this?

 

Regards



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 February 2013 - 11:35 AM

Hi,

 

Can you provide a link to your site please and also, when did this error occur, was it from as soon as you activated PageLines?



#3 trisquelmedia

trisquelmedia

    Super Member

  • Members
  • 151 posts

Posted 21 February 2013 - 11:46 AM

Nop, Pagelines is actived since i upgrated to 2.4.0 version (15 days ago)

 

The URL is

Please Login or Register to see this Hidden Content



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 February 2013 - 12:05 PM

Can you enable PageLines debug mode please:

 

PageLines > Site Options > Advanced



#5 trisquelmedia

trisquelmedia

    Super Member

  • Members
  • 151 posts

Posted 21 February 2013 - 12:13 PM

Yep, enabled!



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 February 2013 - 01:07 PM

Can you disable all non-PageLines plugins and see if this the error appears again. If this only happens every now and again, then if you can please give a day or two. If the error persists, please reply here and we can investigate further.



#7 trisquelmedia

trisquelmedia

    Super Member

  • Members
  • 151 posts

Posted 21 February 2013 - 01:26 PM

Hi:

The error doesnt recur, usually occurs 1 time a week, I'll check if it happens again.

 

Thxs

 

Regards



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 February 2013 - 01:32 PM

OK, well if you can please disable all non-PageLines plugins for a week and see if the issue returns, if it does, reply here and we can investigate further. If it doesn't, then the only way to find the culprit would be enable one plugin at a time, if the error doesn't return, then enable another plugin, repeat the process until the error appears. The last plugin you enable is the culprit.

 

Also, check to see that your plugins have been updated in the last or so and that they're compatible with the latest version of Wordpress. If they haven't you may want to look for alternatives that have.



#9 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 21 February 2013 - 01:52 PM

Unable to allocate memory for pool.

This warning is caused by APC module for PHP, its a memory cache.

You need to ask your host to adjust the pool size.

Its nothing to do with wordpress, or plugins or any theme you are running. APC is an addon module for PHP and is controlled with a php.ini somewhere on the server. Only the server admin can adjust its settings.



#10 trisquelmedia

trisquelmedia

    Super Member

  • Members
  • 151 posts

Posted 21 February 2013 - 02:08 PM

The host support tell me that i should configure the parametres of the plugin that uses APC module, but i dont have many plugin that uses APC...

 

php.info APC configuration is this: what values ‚Äč‚Äčthat should change?

 

Version 3.1.9 APC Debugging Disabled MMAP Support Enabled MMAP File Mask no value Locking type File Locks Serialization Support php Revision $Revision: 308812 $ Build Date Dec 3 2012 10:47:48
Directive Local Value Master Value apc.cache_by_default On On apc.canonicalize On On apc.coredump_unmap Off Off apc.enable_cli Off Off apc.enabled On On apc.file_md5 Off Off apc.file_update_protection 2 2 apc.filters no value no value apc.gc_ttl 3600 3600 apc.include_once_override Off Off apc.lazy_classes Off Off apc.lazy_functions Off Off apc.max_file_size 1M 1M apc.mmap_file_mask no value no value apc.num_files_hint 1000 1000 apc.preload_path no value no value apc.report_autofilter Off Off apc.rfc1867 Off Off apc.rfc1867_freq 0 0 apc.rfc1867_name APC_UPLOAD_PROGRESS APC_UPLOAD_PROGRESS apc.rfc1867_prefix upload_ upload_ apc.rfc1867_ttl 3600 3600 apc.serializer default default apc.shm_segments 1 1 apc.shm_size 32M 32M apc.slam_defense On On apc.stat On On apc.stat_ctime Off Off apc.ttl 0 0 apc.use_request_time On On apc.user_entries_hint 4096 4096 apc.user_ttl 0 0 apc.write_lock On On

#11 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 21 February 2013 - 02:12 PM

APC caches all PHP that es executed, it is an 'opcode cache'

 

I dont know how to adjust its settings, it all depends on how your host have PHP configured. Every server is different.