Jump to content


Photo
- - - - -

How to make a photo pop up from a text link.


Best Answer Rob , 20 February 2013 - 11:15 PM

Christy,

 

If you just go to that page, and after the closing bracket in [/pl_modal], just press Enter on your keyboard and save.

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 christycollins

christycollins

    Super Member

  • Members
  • 179 posts
  • LocationTexas
  • Country: Country Flag

Posted 20 February 2013 - 09:50 PM

[pl_modal title="Lakota 112Y" type="label" colortype="inverse" label="Six Mile Lakota 112Y"]
<img src="

Please Login or Register to see this Hidden Content

" alt="112Y" />
[/pl_modal]
 
 
I want a photo to pop up in a window when they click on this modal. This code is not working. Can you please tell me what I am doing wrong. 
 
Here is the online page that I am working on. It is the grey box at the bottom.
 

Please Login or Register to see this Hidden Content



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 20 February 2013 - 10:09 PM

Hi Christy,

 

I just answered this in your other topic, but I'll give you the same answer again.

 

Please see

Please Login or Register to see this Hidden Content

which is my test of your code.

 

The problem is the trailing space and / before the closing bracket.  " /> is incorrect for use in a modal.  You just need "> to close.

 

Here's the modal I used:

 

Please Login or Register to see this Hidden Content

Wordpress may add a closing /.  Don't worry about that.

 

If this doesn't work, then there may be a plugin conflict.  Please let me know how it goes.



#3 christycollins

christycollins

    Super Member

  • Members
  • 179 posts
  • LocationTexas
  • Country: Country Flag

Posted 20 February 2013 - 10:22 PM

Im guessing this is Rangelone. Thank goodness for you. Sorry about the double post, but the girl that was helping me disappeared I think. 

 

It was a conflict with Fancy Box. I deactivated it and it worked fine.

 

One more question, If I want to add some type (Champion Red Angus Female) below the picture, can you please tell me how I would insert this into the code?

 

 

[pl_modal title="Lakota 112Y" type="label" colortype="inverse" label="Six Mile Lakota 112Y"]
<img src="

Please Login or Register to see this Hidden Content

" alt="112Y">
[/pl_modal]


#4 christycollins

christycollins

    Super Member

  • Members
  • 179 posts
  • LocationTexas
  • Country: Country Flag

Posted 20 February 2013 - 10:43 PM

Can you please look at my page one more time.

 

My boxes don't look as neat as yours, it looks as though the window is not big enough. Also, I would like to have each modal on a new line. 

 

Please Login or Register to see this Hidden Content



#5 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 20 February 2013 - 11:04 PM

Chrissy, I think that's just a layout issue having to do with the image size.  Other than having a minor amount of space causing a slide to appear at the bottom, each looks perfectly fine.  The image is clear, centered and working great in the modal.



#6 christycollins

christycollins

    Super Member

  • Members
  • 179 posts
  • LocationTexas
  • Country: Country Flag

Posted 20 February 2013 - 11:07 PM

Can you tell me how to get each model on a new line. Im sure this is a no brainer.  Make sure you're in Text View when you do this.



#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 20 February 2013 - 11:15 PM   Best Answer

Christy,

 

If you just go to that page, and after the closing bracket in [/pl_modal], just press Enter on your keyboard and save.



#8 christycollins

christycollins

    Super Member

  • Members
  • 179 posts
  • LocationTexas
  • Country: Country Flag

Posted 20 February 2013 - 11:26 PM

Thank you so much for all your good help. Thanks for the patience too!