Archived

This topic is now archived and is closed to further replies.

  • 0

Comments look awful iBlogPro 5 Theme via iPhone 5


Question

Posted · Report post

I'm using iBlog Pro Theme. The latest version, iBlogPro 5. And i'm using an iPhone 5. is that names familiar?

 

iBlogPro 5

iPhone 5

 

You know this theme inspired from Apple. Its looking good on desktop and its plausible on iPad. But iPhone, its horrible.

 

i attached two screenshot from elmadergisi.com Apple blog.

 

screenshots belongs to comments section of a page. Device is iPhone 5 and look at the result please.

 

ElmaDergisi.com site does not have any active plugin that has not belongs to pagelines.

 

i disabled all the plugins but nothing changed.

 

how can we fix this? Maybe, there is no need avatars for comment section. Maybe disabling avatars at comments (mobile theme) works but there is no option for mobile theme... :(

 

Please help for this. i cant say "please turn your device to horizontal position" to my visitors. 

post-31509-0-72050300-1361384761_thumb.j

post-31509-0-28325300-1361384763_thumb.j

 

 

Share this post


Link to post
Share on other sites

17 answers to this question

Posted · Report post

Hi,

 

The corrected CSS needs the prefix for each browser you want to fix this issue on.  The Browser Specific CSS helps you with that.

 

Here's the basic corrected CSS, but again, without the prefix, you need to add it. Please read this documentation first before implementing the code below with the browser specific prefix.

.commentlist {
    line-height: 1.6em;
    list-style-type: none;
    margin: 10px 0 10px 18px;
    padding-left: 5px;
}

.commentlist img.avatar {
    -moz-box-sizing: border-box;
    background: none repeat scroll 0 0 #FBFBFC;
    box-shadow: 0 1px 2px rgba(0, 0, 0, 0.2);
    display: none;
    float: left;
    margin: -5px 5px 5px -85px;
    padding: 2px;
    position: relative;
}
1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Danny. We have still having same problem. We are tracking the issue but nothing changed. How long must we wait? Comments are very important for us and if team can't solve that issue, we must change our theme. Thank you.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

There is still nothing to report at this moment time. As a band aid, you could disable threaded comments, this should make comments looks slightly better for the time being.

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you Rob. I have Browser specific CSS plugin 

 

i'm a rookie at this. 

 

i copied the code but

 

where will i paste it to? and how?  editor/iblogpro/style css? or pagelines/style css?  (i don't think so) 

 

Thank you for your help. i'm waiting your answer.

Share this post


Link to post
Share on other sites

Posted · Report post

Still waiting. will be any update near future? :( 

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I'm sorry to see that you're having problems with iBlogPro5 on your iPhone.  May I ask if you have any custom CSS or custom hooks implemented in your site?

Share this post


Link to post
Share on other sites

Posted · Report post

No, nothing. :( i don't use custom css or hooks

Share this post


Link to post
Share on other sites

Posted · Report post

i find and activate that plugin but nothing changed.

i don't know what to do with that plugin...

 

Its still showing comments like this:

 

post-31509-0-72050300-1361384761_thumb.j

 

its really bad for reading. But the worst is coming when somebody respond to a comment

 

post-31509-0-28325300-1361384763_thumb.j

 

 

i still believe removing frames in comment section may works but i think it is difficult. There may be an option for turning on or of gravatars at comment section. it may work too... 

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there,

 

You can paste your css code directly into Pagelines>site options>custom code if you're just using the standard theme.

 

If you are using the customize plugin or base theme you can add to the style.css, but the easiest option would be to add to the generic site code in Pagelines>site options>custom code.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

Ok, I just tested this with multiple replies and it does indeed look like your screenshot. I have converted your topic to a bug report, thanks for bring this to our attention.

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you very much Danny. i'm waiting the update. Do we wait too long? We couldn't use mobile theme for these reason :(

Share this post


Link to post
Share on other sites

Posted · Report post

I cant give any ETA unfortunately. But the issue has been reported and our developers will look into it.

Share this post


Link to post
Share on other sites

Posted · Report post

Without plugins, custom CSS or hooks, I'm not sure why this would be happening.  I did check your site on IE on my Android phone (I don't have an iPhone or iPad) so I'm guessing this is a browser specific condition.

 

We do have a plugin called Browser Specific CSS (which is free). You may simply need to fine tune the CSS using that plugin, allowing you to move you content where it belongs only in the iOS browsers.

 

You can find that plugin in Dashboard > PageLines > Store > Plugins > Top Free.

Share this post


Link to post
Share on other sites

Posted · Report post

2.4.3 realesed, nothing changed :(

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you Rob and James B. This case solved with your help. That code removes avatar from comment section. Thank you very much.

Share this post


Link to post
Share on other sites

Posted · Report post

You're welcome.

Share this post


Link to post
Share on other sites