Jump to content


Photo
- - - - -

postpins and image scaling

postpins image scaling

  • Please log in to reply
12 replies to this topic

#1 suzyo

suzyo

    Super Member

  • Members
  • 105 posts
  • Country: Country Flag

Posted 19 February 2013 - 10:26 PM

okay, so attached is a  copy of results from google speed test w and w/out postpins.

 

here: 

Please Login or Register to see this Hidden Content

 

on the page linked above you will see the following convo:

 

QUESTION: "Holy cow - this plugin serve scaled images - NOT thumbnail size NOT Medium size BUT Full resolution so I have a page that loads a few MB now?

Page load time: 3.53s

Total page size: 9.03MB

Total number of requests: 46

Websites worked like this 12 years ago - set it to use thumbnails as default or Medium size at leats (sic)."

 

RESPONSE: "Thanks for informing us this issue has been resolved."

 

This was 6 months ago. I got the plugin 6 weeks ago. The images that various speed tests have cited are ALL of the images that are used by postpins vis a vis the attached.

 

So, no, the issue has not been resolved. There is a problem w jquery strings, and also w image scaling. This renders postpins virtually worthless for a large dynamic site. Please advise.

 

p.s.--i love you guys and pagelines rocks!

 

 

 

Attached Files



#2 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 19 February 2013 - 11:09 PM

Hi Suzy, there was a post in between those two, the client said

 

"I've figured this out - but have to re-assign new thumbnails for featured images."

 

So if you set the featured image at the new resolution, it will pull through from there :-)



#3 suzyo

suzyo

    Super Member

  • Members
  • 105 posts
  • Country: Country Flag

Posted 19 February 2013 - 11:34 PM

Hi James! We have to stop meeting like this!

 

Okay, I get that, BUT...all kinds of doohickeys use the featured image thumbnail. grrrrrrrrrrr.

 

I found THIS on another post, should I go ahead and use it? Is it better? Because I'm going to be using jillions of images.

 

Please Login or Register to see this Hidden Content



#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 19 February 2013 - 11:52 PM

I thought postpins was updated to use the smaller thumbnails?

#5 suzyo

suzyo

    Super Member

  • Members
  • 105 posts
  • Country: Country Flag

Posted 20 February 2013 - 12:07 AM

Apparently not, though my research  said that it had been. But, nope. Sure would be nice. : - )



#6 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 20 February 2013 - 01:44 AM

Suzy, I'll check on this tomorrow when everyone's in and give you an update as soon as i know more :-)



#7 suzyo

suzyo

    Super Member

  • Members
  • 105 posts
  • Country: Country Flag

Posted 20 February 2013 - 01:45 AM

thanks, james!



#8 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 20 February 2013 - 02:37 AM

Hey Suzy,

 

I checked back on the product info after seeing Simon's comment on the update. If you look in the meta settings for postpins, there's now a drop down option to be able to select where the images are pulled from. Screenshot attached :-)

 

Please Login or Register to see this Hidden Content

 

If you want to edit the dimensions of any of these sizes you can do so in Settings>media from the Wp admin area.



#9 suzyo

suzyo

    Super Member

  • Members
  • 105 posts
  • Country: Country Flag

Posted 20 February 2013 - 03:12 AM

hi! yeah, no, that field, i don't see it. i see it on your screencast...but i can't find it in my admin.

Attached Files



#10 suzyo

suzyo

    Super Member

  • Members
  • 105 posts
  • Country: Country Flag

Posted 20 February 2013 - 03:16 AM

same thing with site defaults. not there.



#11 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 20 February 2013 - 03:19 AM

Go to the store inside your admin and check which version of postpins you're using. You may need to update.

 

Please Login or Register to see this Hidden Content

 

To update go to Pagelines>dashboard>updates

 

Please Login or Register to see this Hidden Content



#12 suzyo

suzyo

    Super Member

  • Members
  • 105 posts
  • Country: Country Flag

Posted 20 February 2013 - 03:30 AM

Thanks, James, that worked. Why is everything so utterly disconnected? This cost me 4 hours.



#13 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 20 February 2013 - 06:03 AM

Glad that worked for you Suzy :-)

 

Obviously it takes us time to diagnose whats happening and look into a solution for you. But now we know the cause now and you now know you can update the plus plugins through the dashboard :-)







Also tagged with one or more of these keywords: postpins, image scaling