Jump to content


Photo
- - - - -

Fatal Error After All-in-One Event Calendar Update

less.plugin.php fatal error all-in-one event calendar

  • Please log in to reply
11 replies to this topic

#1 commongrounds

commongrounds

    Newbie

  • Members
  • 7 posts
  • LocationBelfast N. Ireland
  • Framework Version:Current one
  • Country: Country Flag

Posted 15 February 2013 - 07:31 AM

Hi,

 

I was in the midst of updating the All-in-one event Calendar update from the "Lite" version to "Standard" when it suddenly started causing a fatal error on my site.

 

The error I am getting is Fatal error: Cannot redeclare class lessc in /home/commodtg/public_html/wp-content/themes/pagelines/includes/less.plugin.php on line 40

 

Needing some help as to how I solve this.

 

Thanks

Nigel



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 February 2013 - 08:21 AM

HI Nigel,

 

When you say "update from the "Lite" version to "Standard" are you referring to PageLines or the plugin?



#3 commongrounds

commongrounds

    Newbie

  • Members
  • 7 posts
  • LocationBelfast N. Ireland
  • Framework Version:Current one
  • Country: Country Flag

Posted 15 February 2013 - 08:33 AM

I was referring to the plugin, it was after the plugin update that the error occured.

 

Nigel



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 February 2013 - 08:45 AM

What version of Wordpress and PageLines are you using ?

Also, I don't have access to the Pro version, can you send it to me danny at pagelines dot com

 

So I can run the update myself.



#5 commongrounds

commongrounds

    Newbie

  • Members
  • 7 posts
  • LocationBelfast N. Ireland
  • Framework Version:Current one
  • Country: Country Flag

Posted 15 February 2013 - 08:54 AM

Sorry, bit of a novice so treat me gently..

 

How do I tell the wordpress and pagelines version from the source code as I cant access the backend due to the error. And what exactly do you want me to send you?

 

Nigel



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 February 2013 - 09:11 AM

With the issue on your site, you will need to use your FTP client and connect to your site. In the main directory where the Wordpress folder/files are located. There should be a file called "readme.html", this will let you know what version of Wordpress you're using.

 

To find what version of PageLines you're using, using your FTP client again, navigate to wp-content/themes/pagelines and then view the style.css file, this will inform you the version of PageLines you're using.

 

I will need you to send me the plugin, as you're using the premium version, then I can attempt to upgrade and see if I receive the same error.



#7 commongrounds

commongrounds

    Newbie

  • Members
  • 7 posts
  • LocationBelfast N. Ireland
  • Framework Version:Current one
  • Country: Country Flag

Posted 15 February 2013 - 09:15 AM

Just to clarify, I dont have the pro version of this plugin, I had an old version, called the "lite" version, I had updated the plugin to the current version and was then prompted to updated to the standard version for free. So it was the update from lite to standard that caused the problem,

 

The Lite version I am referring to is mentioned at the bottom of this page 

Please Login or Register to see this Hidden Content

 

Nigel



#8 commongrounds

commongrounds

    Newbie

  • Members
  • 7 posts
  • LocationBelfast N. Ireland
  • Framework Version:Current one
  • Country: Country Flag

Posted 15 February 2013 - 09:18 AM

Wordpress version is 3.5.1

 

Pagelines version is 2.3.8

 

Cheers



#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 February 2013 - 09:55 AM

OK, do you have a backup of your site?

If so, using your FTP client navigate to wp-content/plugins/

 

Then rename the all-in-one-event-calendar folder to something like this:

old_all-in-one-event-calendar

 

Then see if this resolves your issue.



#10 commongrounds

commongrounds

    Newbie

  • Members
  • 7 posts
  • LocationBelfast N. Ireland
  • Framework Version:Current one
  • Country: Country Flag

Posted 15 February 2013 - 01:00 PM

Ok that got the site back up again, thanks.

 

Should I go ahead and reinstall this plugin then?

 

Thanks

 

Nigel



#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 February 2013 - 01:48 PM

Yes, try again and see if this has resolved your issue. If you receive the error again, then I recommend you do as I suggested above to resolve the issue and then disable all active plugins and install the calendar plugin again.

 



#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 15 February 2013 - 03:07 PM

Update PageLines Framework 1st, this was fixed in v2.4







Also tagged with one or more of these keywords: less.plugin.php, fatal error, all-in-one event calendar