Jump to content


Photo
- - - - -

Cannot upgrade to PageLines 2.4


  • Please log in to reply
9 replies to this topic

#1 mrossen

mrossen

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 14 February 2013 - 05:12 PM

I am a big fan of PageLines and use it for all my sites. However, I am having a problem upgrading to the PageLines Framework 2.4. Unlike previous upgrades, each time I try to upgrade to this latest version, my site's layout disappears. When I revert to the older version, it comes back.

 

I have tried this on more than one WordPress site that I maintain and I get the same result with each. Are you aware of others having this same problem?

 

I am using the latest version of WordPress on all of my sites. My host is HostGator.

 

I would like to keep my theme up-to-date, but I do not want to lose all of my layouts that I have worked so hard to set-up.

 

 

Thank you in advance for all your assistance with this issue.



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 14 February 2013 - 05:31 PM

Can you please post a link to your site?



#3 mrossen

mrossen

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 14 February 2013 - 05:34 PM

supremebarreview.com



#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 14 February 2013 - 05:55 PM

Can you please upgrade to 2.4 so I can see the site when it's blank and also, please enable debug (see here for instructions:

Please Login or Register to see this Hidden Content

).



#5 mrossen

mrossen

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 14 February 2013 - 06:23 PM

I just tried to upgrade my site at supremebarreview.com to 2.4 and it worked this time without messing up my layout.

 

So I decided to try upgrading one of my other sites to 2.4. When I did, I lost all of the formatting on that site. You can see that other WordPress site at ToyGunslinger.com

 

If you want to see what it looked like BEFORE the upgrade to 2.4, let me know and I can reinstall the previous version of Pagelines. 

 

I have other sites that use Pagelines as well that have not yet upgraded due to this same issue. You can view another site of mine at: biztycoon.com. If you want me to try to upgrade that one to 2.4 as well, let me know but I wanted you to see it first before I upgrade it so you can see the difference.

 

Thanks.



#6 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 February 2013 - 07:13 PM

Your site is trying to get the css from a https:// url and its resulting in a 404 error. Did you have ssl enabled before and add extra code to force ssl on one page? If so remove that code.



#7 mrossen

mrossen

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 14 February 2013 - 08:32 PM

There is no SSL certificate on this particular site or on the other sites that I am trying to upgrade to 2.4. I just called my hosting service Hostgator and confirmed this with them. They checked the htaccess files and did not see any ssl certificates. There are no "https://" pages on the site. 

 

Could there be something else causing this to occur? I have gone through many upgrades of Pagelines without this error occurring. Is there something in version 2.4 that is causing this error? 



#8 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 February 2013 - 08:39 PM

No, by default if the site is http, then all internal links will be http as well, unless you have added special code to make certain pages be https.



#9 mrossen

mrossen

    Newbie

  • Members
  • 5 posts
  • Country: Country Flag

Posted 14 February 2013 - 08:59 PM

I did not add any code to make pages https. Therefore, I am unable to implement your suggested solution to this issue.

 

Can you suggest another way to make this work?

 

I had to revert my site back to the previous version of Pagelines in order for it to display properly. Am I stuck with the old version? Should I wait for the next update and try again?

 

Not sure what to do next. Thanks.



#10 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 February 2013 - 09:58 PM

As i said there is no way at all, ever in a million years that the framework would just make one css url https, its impossible.

 

If you want me to log in and find out what previous code is making it do this then just PM me an admin login.