Jump to content


Photo
- - - - -

Moving pagelines Site


  • Please log in to reply
11 replies to this topic

#1 smv_usdam

smv_usdam

    Member

  • Members
  • 21 posts
  • Country: Country Flag

Posted 13 February 2013 - 02:51 PM

Hi,

 

I'm trying to move a Wordpress site with pagelines pro theme from a subdomain to a subdirectory (/wp) of the same domain, so everything on the same server. I'm following the instructions given here: 

Please Login or Register to see this Hidden Content

I'm now at point 9 of: "When Your Domain Name or URLs Change">"On Your Existing Server": I have changed the Wordpress address and the Site address in Wordpress setting>general, and copied all the files to the new directory. Now, when I'm trying to connect to

Please Login or Register to see this Hidden Content

I get one of the following three errors for every pagelines section:

 

Warning: is_file() [

Please Login or Register to see this Hidden Content

]: open_basedir restriction in effect. File(/home/httpd/vhosts/mydomain.com/subdomains/wordpress/httpdocs/wp-content/themes/pagelines/sections/boxes/section.php) is not within the allowed path(s): (/home/httpd/vhosts/mydomain.com/httpdocs:/tmp:/usr/share/pear) in /home/httpd/vhosts/mydomain.com/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php on line 130

 

Warning: is_file() [

Please Login or Register to see this Hidden Content

]: open_basedir restriction in effect. File(/home/httpd/vhosts/mydomain.com/subdomains/wordpress/httpdocs/wp-content/plugins/pagelines-sections/pagelines-soapbox/section.php) is not within the allowed path(s): (/home/httpd/vhosts/mydomain.com/httpdocs:/tmp:/usr/share/pear) in /home/httpd/vhosts/mydomain.com/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php on line 135


Warning: is_file() [

Please Login or Register to see this Hidden Content

]: open_basedir restriction in effect. File(/home/httpd/vhosts/mydomain.com/subdomains/wordpress/httpdocs/wp-content/plugins/pagelines-sections/fittext-section/section.php) is not within the allowed path(s): (/home/httpd/vhosts/mydomain.com/httpdocs:/tmp:/usr/share/pear) in /home/httpd/vhosts/mydomain.com/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php on line 140

 

 

and only ONE other error:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/mydomain.com/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php:140) in/home/httpd/vhosts/mydomain.com/httpdocs/wp/wp-includes/pluggable.php on line 876

 

 

It seems, page lines has stored URLs of the sections somewhere and is still referencing to this, but I don't find anything relevant in the database.

 

What to do?



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 13 February 2013 - 03:08 PM

I searched around and found this solution:

Please Login or Register to see this Hidden Content

You should try it out and try accessing your site log-in again.



#3 smv_usdam

smv_usdam

    Member

  • Members
  • 21 posts
  • Country: Country Flag

Posted 13 February 2013 - 03:16 PM

Catrina,

 

I don't think this is it. To modify the 

Please Login or Register to see this Hidden Content

 will not change the fact that class.register.php is looking for the sections in the subdomain where they aren't anymore. So these URLs must be stored somewhere and can hopefully be adjusted, but where?



#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 February 2013 - 03:25 PM

Go to /wp-admin/admin.php?page=pagelines_extend it will rebuild the sections caches.



#5 smv_usdam

smv_usdam

    Member

  • Members
  • 21 posts
  • Country: Country Flag

Posted 13 February 2013 - 03:30 PM

Unfortunately this gives the exact same errors.

I suppose for this to work I would have to be logged in, but I don't get that far.



#6 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 February 2013 - 03:31 PM

Yes you would have to be logged in, of couse you could just turn off error logging, should be off anyway on a production server.



#7 smv_usdam

smv_usdam

    Member

  • Members
  • 21 posts
  • Country: Country Flag

Posted 13 February 2013 - 03:56 PM

OK, I managed to log-in. Then I get the following errors in addition to the ones mentioned above:

 


Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/smv.ch/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php:140) in/home/httpd/vhosts/smv.ch/httpdocs/wp/wp-login.php on line 368

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/smv.ch/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php:140) in/home/httpd/vhosts/smv.ch/httpdocs/wp/wp-login.php on line 380

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/smv.ch/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php:140) in/home/httpd/vhosts/smv.ch/httpdocs/wp/wp-includes/pluggable.php on line 680

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/smv.ch/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php:140) in/home/httpd/vhosts/smv.ch/httpdocs/wp/wp-includes/pluggable.php on line 681

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/smv.ch/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php:140) in/home/httpd/vhosts/smv.ch/httpdocs/wp/wp-includes/pluggable.php on line 682

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/smv.ch/httpdocs/wp/wp-content/themes/pagelines/includes/class.register.php:140) in/home/httpd/vhosts/smv.ch/httpdocs/wp/wp-includes/pluggable.php on line 876

 

 

If I go to /wp-admin/admin.php?page=pagelines_extend, as you suggested; i get the same errors as in my first post. And that's the only thing displayed.

 

I have now turned error logging off and emptied the cache. The result is still the same. What to do?



#8 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 February 2013 - 03:57 PM

OK so go to the store page and click the blue refresh button.



#9 smv_usdam

smv_usdam

    Member

  • Members
  • 21 posts
  • Country: Country Flag

Posted 13 February 2013 - 04:07 PM

How should I go to the store page? I don't see anything apart from the error messages.



#10 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 February 2013 - 04:08 PM

I thought you said you turned off error logging?



#11 smv_usdam

smv_usdam

    Member

  • Members
  • 21 posts
  • Country: Country Flag

Posted 13 February 2013 - 04:11 PM

Yes, I turned off log_errors  in the PHP settings of the server.

Did you mean to turn off display_errors  ?



#12 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 February 2013 - 04:15 PM

As i said before, a production server should not show any php errors by default, thats what WP_DEBUG setting does in wp-config.php, it turns them all on so you can debug plugins themes etc.