Jump to content


Photo
- - - - -

Jigoshop display problem in Internet Explorer

Jigoshop Internet Explorer View Shopping Cart

Best Answer Simon_P , 13 February 2013 - 10:14 PM

.product-thumbnail img {
    max-width: 80px !important;
}
 
That fixed it. Added it to your custom css.
Go to the full post


  • Please log in to reply
19 replies to this topic

#1 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 10 February 2013 - 07:24 AM

Website:

Please Login or Register to see this Hidden Content

Internet Explorer 9

Latest Version of Pagelines & Jigoshop

 

Using Internet Explorer, please go to 

Please Login or Register to see this Hidden Content

 

Add any item to your shopping cart (except for the "Test" item). Then click "View Shopping Cart".

 

You'll notice that the picture of the merchandise is over-sized. This only happens in Internet Explorer. The item displays fine in Chrome and Firefox.

 

Has anyone else experienced this? Does anyone have a solution?

 

Thanks,

 

Jeff



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17139 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 10 February 2013 - 02:09 PM

Hi Jeff,

 

What version of IE is this happening on and also if you disable PageLines Framework and enable Twenty Twelve, does the issue persist ?



#3 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 11 February 2013 - 03:45 PM

Hi Danny,

 

Internet Explorer 9

 

The problem does NOT happen when the Twenty Twelve theme is activated.

 

Any ideas?

 

Thanks,

 

Jeff



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 11 February 2013 - 11:08 PM

Jeff,

 

Danny will be in early in the morning.

 

I've let him know that I have tested your site in IE9 and it's exactly as described.  Just as an aside, IE9 is notorious for not scaling images.  It may be necessary to replace the very large images with ones that are manually resized to standard dimensions.



#5 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 February 2013 - 11:38 PM

This is caused by an Internet Explorer hack for ie8. ( i think ) Anyway if you'd like to test....

 

open pagelines/less/pl-core.less in an editor with line numbers.

 

Find line 589 and change it to this:

 

width/*\**/: auto\9 /* ie8 */

 

The resave settings to cache new css.



#6 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 12 February 2013 - 08:21 PM

Hi Simon,

 

How do I find pagelines/less/pl-core.less?

 

Sorry about the novice question.

 

Thanks,

 

Jeff



#7 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 February 2013 - 08:30 PM

wp-content/themes/pagelines/less/pl-core.less



#8 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 12 February 2013 - 08:43 PM

Hi Simon,

 

Ok, I found it using Filezilla and downloaded it to my computer.

 

What program to I use to open it and add the code? I even tried to change the extension but didn't have much luck opening it.

 

Thanks,

 

Jeff



#9 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 February 2013 - 09:00 PM

Does filezilla not have right-click edit file?

 

If not you could edit it in wordpress admin in the theme editor. 

 

I also added the file to this reply

Attached Files



#10 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 12 February 2013 - 09:24 PM

Hi Simon,

 

It does have right-click edit file. Sorry about that. I'm a novice when it comes to programming and didn't know that.

 

When I opened it, it is displayed in a giant paragraph of code in Note Pad. Since it's not in line item format, I'm not sure how to find Line 589?

 

Is the file you attached an edited version with the corrected code that I can just insert and replace the existing file?

 

Thanks for your help,

 

Jef



#11 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 February 2013 - 09:26 PM

yes just unzip, upload into the same place, then go to wp-admin and click save in a pagelines area.



#12 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 13 February 2013 - 01:49 AM

Hey Simon,

 

I unzipped and overwrote the existing file in Filezilla. It saved and refreshed.

 

Not sure what you meant when you said to go to wp-admin and click save. Didn't see a way to do that, or I just don't know how.

 

The website still behaves the same in Internet Explorer 9. Any ideas?

 

Thanks for your help so far. I really appreciate it.

 

Jeff



#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 13 February 2013 - 05:46 AM

Jeff, I've alerted Simon to your reply.  He'll answer as soon as he's able to and receives my email on Wednesday.



#14 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 February 2013 - 02:20 PM

Hey Simon,

 

I unzipped and overwrote the existing file in Filezilla. It saved and refreshed.

 

Not sure what you meant when you said to go to wp-admin and click save. Didn't see a way to do that, or I just don't know how.

 

The website still behaves the same in Internet Explorer 9. Any ideas?

 

Thanks for your help so far. I really appreciate it.

 

Jeff

 

Log into your wordpress site, click the pagelines site options link on the left then click the big blue save button, this will force the css to be rewritten.



#15 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 13 February 2013 - 05:45 PM

Hi Simon,

 

I tried it, but no luck. Same display problems.

 

Any other ideas?

 

Thanks for your help,

 

Jeff



#16 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 February 2013 - 06:10 PM

Id need to take a look in the admin if thats ok, please send me a private message on the forums with a username/password.



#17 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 13 February 2013 - 08:56 PM

Hi Simon, 

 

I set up an Admin account for you and sent the login details in a private message.

 

Thanks for all your help,

 

Jeff



#18 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 February 2013 - 10:14 PM   Best Answer

.product-thumbnail img {
    max-width: 80px !important;
}
 
That fixed it. Added it to your custom css.


#19 jwchameleoncorp

jwchameleoncorp

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 14 February 2013 - 12:53 AM

Just checked it...YOU'RE THE KING!!!

 

I owe you a beer!

 

Thanks a ton for your help!



#20 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 14 February 2013 - 01:00 AM

Your welcome.







Also tagged with one or more of these keywords: Jigoshop, Internet Explorer, View Shopping Cart