Archived

This topic is now archived and is closed to further replies.

  • 0

Slider problems


Question

Posted · Report post

Hi robert

Share this post


Link to post
Share on other sites

41 answers to this question

Posted · Report post

Hi Mike,

 

I know this is frustrating, but please do understand every developer codes differently, we have no way of directly knowing how this was performed and very rarely does a developer want to hand over their source code.  However we always want solutions the best way we can see fit, so we do from time to time work directly with a developer that wants to port over their product to be PageLines compatible.  This means going back and fourth with the developer and them working on making changes to their code.  I hope this clarifies.  We don't have control over other Developer's plugins, that's why we have a whole developer community where we focus on training them to create products and port some of their other products over.

 

If you have any other questions we are happy to help, but i apologize the solution was not within our control.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Meilena,

 

Robert bought a copy of the plugin so I thought your developer was looking at it.

Share this post


Link to post
Share on other sites

Posted · Report post

Right, got to the bottom of this.

 

You are using the shortcode in the wrong place.

 

If you place the shortcode in the content area, then the slider is going to be restricted to that area. Same goes if you place it in the header.

 

You wanted the slider at the top of the page and to go full width right? So you have to insert the shortcode before the framework starts to draw out all the responsive areas.

For that you wil need to use a wp action.

 

So install and activate the pagelines-customization plugin or use a child theme, choice is yours here.

 

Now add this snippet to the functions.php file in either the plugin or child theme.

 

 

 

add_action( 'pagelines_before_page', 'draw_myslides' );

function draw_myslides() {

    echo do_shortcode( '[lbg_zoominoutslider settings_id="1"]' );
}
 

That will insert your shortcode right at the top.

Share this post


Link to post
Share on other sites

Posted · Report post

Robert took a look at it, but I can't seem to find what he said about his experience with it. I'll need to ask him later when he signs on.

Share this post


Link to post
Share on other sites

Posted · Report post

When I add that code to the functions.php file in the child theme "Base" it breaks the site.

Share this post


Link to post
Share on other sites

Posted · Report post

obviously im not doing it right

Share this post


Link to post
Share on other sites

Posted · Report post

[lbg_kenburnsslider settings_id='2'] is the actual shortcode

I think I uploaded the file you asked for as well as image

Share this post


Link to post
Share on other sites

Posted · Report post

add_action( 'pagelines_before_page', 'draw_myslides' );
 
function draw_myslides() {
 
    echo do_shortcode( '[lbg_kenburnsslider settings_id='2']' );
}

Share this post


Link to post
Share on other sites

Posted · Report post

Robert should be back online in a few hours

Share this post


Link to post
Share on other sites

Posted · Report post

Ah yes i see, you changed the single quotes to double quotes.

 

add_action( 'pagelines_before_page', 'draw_myslides' );

function draw_myslides() {

    echo do_shortcode( '[lbg_kenburnsslider settings_id="2"]' );
}

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Mike,

 

As you know, I came into the end of the discussion of Live, not the beginning, so please give a bit more detail here so my colleagues and I can dig a bit further.

 

I must point out that in testing the product so far,  you seem to have its settings and concept backwards.

 

The plugin is designed to expand an image to full width.  That means you do not need a 2744px wide image to fill the screen. This is why it's important to read instructions for plugins. 

 

I've been able to make the plugin work on my own site, however, because the shortcode is going into the canvas area it doesn't align left.  If that was the problem you were experiencing, it may be simply that the canvas area is never full width.

 

To make the shortcode work in a full-width area one would have to apply it to a full width section such as the header.

 

You can try placing the Full Width or Universal Sidebar in the header area as the last item, then apply a text widget and include the shortcode in there. Make sure the layout is full width responsive with % width.

 

I will continue testing, provided I have power.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

more than happy to let you go in and have a look around and fix it

Share this post


Link to post
Share on other sites

Posted · Report post

ok sure PM me a login

Share this post


Link to post
Share on other sites

Posted · Report post

did it same problem

Share this post


Link to post
Share on other sites

Posted · Report post

Robert bought the slider too if you look at the beginning of these posts. sent you the login

Share this post


Link to post
Share on other sites

Posted · Report post

I actually need it to be under the header

Share this post


Link to post
Share on other sites

Posted · Report post

right...

Share this post


Link to post
Share on other sites

Posted · Report post

I actually need it to be alot of places

Share this post


Link to post
Share on other sites

Posted · Report post

You cant have a full width element inside another element that isn't full width.

 

You can place that action code anywhere by just changing the action 'hook' in this case it was pagelines_before_page.

 

if you install the free action map plugin you will see there are 100's of these hooks on every page, but they are nearly all inside the page canvas area.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Mike,

 

This is actually an escalated issue, so I am going to be consulting with our developer to see if there is anything else we can do on our end to advise you further.  We will be in contact when we have more information available.

Share this post


Link to post
Share on other sites

Posted · Report post

I realize that and already have the plugin. So I guess you solution doent work?

Share this post


Link to post
Share on other sites

Posted · Report post

The header is supposed to be full width is it not?

Share this post


Link to post
Share on other sites

Posted · Report post

I really need to turn off the pagelines .img definitions for a section. I had the action map plugin but one of the developers told me to disable it

Share this post


Link to post
Share on other sites