Jump to content


Photo
- - - - -

LazyLoader plugin and thumbnail issue

LazyLoader

Best Answer Jean-Philippe , 10 February 2013 - 01:06 AM

Ok, I found the solution.

I was using WP-OGP plugin and it seems it was in conflict with LazyLoader.

So I deactivated WP-OGP plugin and I turned on WordPress SEO "Add OpenGraph meta data" option.

Now everything works well  :)

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 Jean-Philippe

Jean-Philippe

    Super Member

  • Members

  • 115 posts
  • LocationTokyo
  • Country: Country Flag

Posted 08 February 2013 - 12:32 PM

Hi there,

 

I noticed that if LazyLoader plugin is activated and I want to share a single post from my website to Facebook or Google+, I won't have any thumbnail (impossible to select any).

 

Once LazyLoader is deactivated, everything is ok and thumbnails appears when sharing a single post to FB or G+.

 

Is it normal or is it a bug? How can I fix this issue?

 

Thank you for your help!

 

Jean-Philippe



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 09:46 PM

Hi Jean-Philippe,

 

Like any plugin, LazyLoader can cause issues, particularly with third party sites, plugins, sections etc.  So this is normal.  What you can do, surprisingly, is go to the topic in FB and use their settings to select the image from the post on your site.  FB loads all images, displaying one only, but it gives you the chance to change the image selection if you prefer a different one.

 

I don't think this is anything serious.  Likely LazyLoader simply loads the thumbnail in a different sequence than when deactivated, so FB is just picking up the first image loaded.

 

Hopefully this explains and helps you resolve this issue.



#3 Jean-Philippe

Jean-Philippe

    Super Member

  • Members

  • 115 posts
  • LocationTokyo
  • Country: Country Flag

Posted 10 February 2013 - 12:28 AM

Thank you for your answer Rob.

The problem is I can't select any thumbnail in FB (or Google+) when sharing a post because they actually don't recognize any images!

It seems that LazyLoader plugin prevents third party sites from catching images displayed on a single post or a page.



#4 Jean-Philippe

Jean-Philippe

    Super Member

  • Members

  • 115 posts
  • LocationTokyo
  • Country: Country Flag

Posted 10 February 2013 - 01:06 AM   Best Answer

Ok, I found the solution.

I was using WP-OGP plugin and it seems it was in conflict with LazyLoader.

So I deactivated WP-OGP plugin and I turned on WordPress SEO "Add OpenGraph meta data" option.

Now everything works well  :)